Allow SRCREV handling through poky-agl.conf
[AGL/meta-agl.git] / meta-app-framework / recipes-example / afb-client / afb-client_1.0.bb
1 SUMMARY = "HTML5 demo template for AFB"
2 DESCRIPTION = "afb-client is a sample AngularJS/HTML5 application using \
3 Application Framework Binder with token binding."
4 HOMEPAGE = "http://www.iot.bzh"
5
6 LICENSE = "GPLv3+"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=6cb04bdb88e11107e3af4d8e3f301be5"
8
9 #DEPENDS = "nodejs-native"
10 RDEPENDS_${PN} = "af-binder af-binder-binding-authlogin"
11
12 SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-demo;protocol=https;branch=${AGL_BRANCH}"
13 SRC_URI_files = "file://afb-client \
14           "
15 SRC_URI = "${SRC_URI_git} \
16            ${SRC_URI_files} \
17           "
18 SRCREV = "9e9b459fa27d7a359a060024c9639b99b45813d5"
19 S = "${WORKDIR}/git/afb-client"
20
21 do_install () {
22   mkdir -p ${D}/${datadir}/agl/afb-client
23   cp -ra ${S}/dist.prod/* ${D}/${datadir}/agl/afb-client/
24
25   mkdir -p ${D}/${bindir}
26   install -m 0755 ${WORKDIR}/afb-client ${D}/${bindir}/afb-client
27 }
28
29 FILES_${PN} += "${datadir}"