Remove use of AGL_APP_REVISION
[AGL/meta-agl.git] / meta-app-framework / recipes-core / applaunchd / applaunchd_git.bb
1 SUMMARY     = "AGL Application Launcher service"
2 DESCRIPTION = "AGL Application Launcher service build with recipe method"
3 HOMEPAGE    = "https://git.automotivelinux.org/src/applaunchd"
4 SECTION     = "apps"
5 LICENSE     = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
7
8 DEPENDS = " \
9     glib-2.0 \
10     glib-2.0-native \
11 "
12
13 PV      = "1.0+git${SRCPV}"
14
15 SRC_URI = " \
16         git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH}  \
17         "
18 SRCREV = "c84836ec5ddaf2d0e91c46713475c35652bb540f"
19
20 S       = "${WORKDIR}/git"
21
22 inherit meson pkgconfig
23
24 FILES:${PN} += " ${datadir}/dbus-1/"
25
26 RDEPENDS:${PN} += " \
27     agl-session \
28 "