Update github.com git:// SRC_URIs
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-main / nativesdk-af-main_git.bb
1 require af-main_${PV}.inc 
2
3 inherit nativesdk cmake pkgconfig 
4
5 SECTION = "base"
6
7 DEPENDS = "nativesdk-openssl nativesdk-libxml2 nativesdk-xmlsec1 nativesdk-libzip nativesdk-json-c"
8
9 EXTRA_OECMAKE = "\
10         -DUSE_LIBZIP=1 \
11         -DUSE_SIMULATION=1 \
12         -DUSE_SDK=1 \
13         -DAGLVERSION=${AGLVERSION} \
14         -Dafm_name=${afm_name} \
15         -Dafm_confdir=${afm_confdir} \
16         -Dafm_datadir=${afm_datadir} \
17 "
18
19 do_install:append() {
20     # remove unused .pc file we don't want to package
21         rm -rf ${D}/${libdir}
22 }
23
24 PACKAGES = "${PN}-tools ${PN}-tools-dbg"
25 FILES:${PN}-tools = "${bindir}/wgtpkg-* ${afm_confdir}/*"
26 FILES:${PN}-tools:append:agl-sign-wgts = " ${datadir}/afm"
27 FILES:${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"