[RCAR] disable a default config in kernel
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / weston_8.0.%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://0001-Allow-regular-users-to-launch-Weston_7.0.0.patch \
5     file://0001-libweston-Expose-weston_output_damage-in-libweston.patch \
6     file://0001-libweston-Migrate-weston_seat_init-release-to-public.patch \
7     file://0005-correctly-tear-down-drm-backend.patch \
8     file://smack-weston \
9     "
10
11 EXTRA_OEMESON_append = " -Denable-user-start=true"
12
13 # Workaround for incorrect upstream definition
14 PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
15 PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
16
17 do_install_append() {
18     if ${@bb.utils.contains('DISTRO_FEATURES', 'smack', 'true', 'false', d)}; then
19         # Install SMACK rules
20         install -D -m 0644 ${WORKDIR}/smack-weston ${D}${sysconfdir}/smack/accesses.d/weston
21     fi
22 }
23
24 FILES_${PN} += "\
25     ${sysconfdir}/smack/accesses.d/* \
26 "