meta-agl-profile-core: add pyagl to agl-devel images
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / pyagl / pyagl_git.bb
1 SUMMARY = "Python bindings and tests for Automotive Grade Linux services"
2 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/pyagl"
3 LICENSE = "Apache-2.0"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
5
6 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/pyagl;protocol=https;branch=${AGL_BRANCH}"
7 SRCREV = "f583233db298a709a813d8c0af97769ba30ae002"
8 PV = "${AGL_BRANCH}+git${SRCPV}"
9
10 S = "${WORKDIR}/git"
11
12 inherit setuptools3
13
14 RDEPENDS_${PN} += " \
15     python3-asyncio \
16     python3-asyncssh \
17     python3-core \
18     python3-json \
19     python3-logging \
20     python3-math \
21     python3-parse \
22     python3-pprint \
23     python3-pytest \
24     python3-pytest-asyncio \
25     python3-pytest-dependency \
26     python3-pytest-reverse \
27     python3-typing \
28     python3-websockets \
29 "