[RCAR] disable a default config in kernel
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / freetype / freetype_2.%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 SRC_URI =+ "${SOURCEFORGE_MIRROR}/freetype/freetype-demos/${PV}/ft2demos-${PV}.tar.gz;name=ft2demos \
4            file://0001-Makefile-dont-build-gfx-demos.patch;patchdir=../ft2demos-${PV} \
5            file://0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch;patchdir=../ft2demos-${PV} \
6           "
7 SRC_URI[ft2demos.md5sum] = "c376adf4782bac9b9ac8e427884752d2"
8 SRC_URI[ft2demos.sha256sum] = "5e9e94a2db9d1a945293a1644a502f6664a2173a454d4a55b19695e2e2f4a0bc"
9
10 PACKAGES =+ "${PN}-demos"
11
12 B = "${S}"
13
14 do_compile_append () {
15     oe_runmake -C ${WORKDIR}/ft2demos-${PV} TOP_DIR=${WORKDIR}/${BPN}-${PV}/
16 }
17
18 do_install_append () {
19     install -d -m 0755 ${D}/${bindir}
20     for x in ftbench ftdump ftlint ftvalid ttdebug; do
21         install -m 0755 ${WORKDIR}/ft2demos-${PV}/bin/.libs/$x ${D}/${bindir}
22     done
23 }
24
25 FILES_${PN}-demos = "\
26     ${bindir}/ftbench \
27     ${bindir}/ftdump \
28     ${bindir}/ftlint \
29     ${bindir}/ftvalid \
30     ${bindir}/ttdebug \
31 "
32
33 # enable pixmap/libpng support to allow color emojis
34 PACKAGECONFIG_append = " pixmap"