[RCAR] disable a default config in kernel
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / aiostress / aiostress_0.22.bb
1 SUMMARY = "Async IO testing utility"
2 DESCRIPTION = "aio-stress will open or create each file on the command line, and start a series of aio to it.\
3 aio is done in a rotating loop.  first file1 gets 8 requests, then file2, then file3 etc.\
4 As each file finishes writing, it is switched to reads io buffers are aligned in case you want to do raw io"
5 HOMEPAGE = "https://oss.oracle.com/~mason/aio-stress/"
6 LICENSE = "GPLv2"
7
8 S="${WORKDIR}"
9
10 LIC_FILES_CHKSUM = "file://${S}/aio-stress.c;md5=ccb5d196a3736bbd835d582a4e2329c3"
11
12 SRC_URI = "https://oss.oracle.com/~mason/aio-stress/aio-stress.c"
13 SRC_URI[md5sum] = "ccb5d196a3736bbd835d582a4e2329c3"
14 SRC_URI[sha256sum] = "3f4cffcc946fb717fff9d8fe932c7c2ee606efff198408d9fbe16955151445f7"
15
16 do_compile () {
17         ${CC} -Wall -Wshadow -o aio-stress -lpthread -laio aio-stress.c
18 }
19
20 do_install () {
21         install -d ${D}${bindir}
22         install -m 0755 aio-stress ${D}${bindir}
23 }
24