[RCAR] disable a default config in kernel
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-navigation / gpsd / gpsd_%.bbappend
1 SYSTEMD_SERVICE_${PN} += " gpsdctl@.service"
2
3 RPROVIDES_${PN}-conf += "virtual/gpsd-conf"
4
5 do_install_append() {
6     # use the systemd compatible gpsd.rules
7     install -d ${D}/${sysconfdir}/udev/rules.d
8     install -m 0644 ${S}/gpsd.rules ${D}/${sysconfdir}/udev/rules.d/60-gpsd.rules
9
10     #support for systemd
11     install -d ${D}${systemd_unitdir}/system/
12     install -m 0644 ${S}/systemd/gpsdctl@.service ${D}${systemd_unitdir}/system
13
14     #autoprobe usb gps devices
15     echo 'USBAUTO="true"' >> ${D}${sysconfdir}/default/gpsd.default
16 }