wayland/weston-ini-conf: Add transmitter-output ini section
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / wayland / waltham-transmitter_git.bb
1 DESCRIPTION = "Waltham is a network IPC library designed to resemble Wayland both protocol and protocol-API wise"
2 HOMEPAGE = "https://github.com/waltham/waltham"
3
4 LICENSE = "MIT"
5 LIC_FILES_CHKSUM = "file://waltham-transmitter/COPYING;md5=f21c9af4de068fb53b83f0b37d262ec3"
6
7 DEPENDS += "libdrm virtual/kernel wayland wayland-native waltham weston gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad wayland-ivi-extension"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/weston-ivi-plugins.git;protocol=https;branch=${AGL_BRANCH}"
10 SRCREV = "5287483228fa1e28f3217a54606cfe760c6582bd"
11
12 S = "${WORKDIR}/git/"
13
14 WALTHAM_PIPELINE_TRANSMITTER ?= "waltham-transmitter/waltham-renderer/pipeline_example_general.cfg"
15 WALTHAM_PIPELINE_RECEIVER ?= "waltham-receiver/receiver_pipeline_example_general.cfg"
16 WALTHAM_RECIEVER_IP ?= "192.168.1.2"
17 WALTHAM_RECEIVER_PORT ?= "3440"
18
19 inherit pkgconfig cmake
20
21 do_install_append () {
22    install -d ${D}/etc/xdg/weston/
23    install ${S}/${WALTHAM_PIPELINE_TRANSMITTER} ${D}/etc/xdg/weston/transmitter_pipeline.cfg
24    install ${S}/${WALTHAM_PIPELINE_RECEIVER} ${D}/etc/xdg/weston/receiver_pipeline.cfg
25
26    sed -i -e "s/YOUR_RECIEVER_IP/${WALTHAM_RECIEVER_IP}/g" ${D}/etc/xdg/weston/transmitter_pipeline.cfg
27    sed -i -e "s/YOUR_RECIEVER_PORT/${WALTHAM_RECEIVER_PORT}/g" ${D}/etc/xdg/weston/transmitter_pipeline.cfg
28    sed -i -e "s/YOUR_RECIEVER_PORT/${WALTHAM_RECEIVER_PORT}/g" ${D}/etc/xdg/weston/receiver_pipeline.cfg
29
30 }
31
32 FILES_${PN} += "/etc/xdg/weston/*.cfg"
33 FILES_${PN} += "${libdir}/*"
34 FILES_${PN} += "${bindir}/*"