agl-compositor_git: Bump SRCREV to latest
[AGL/meta-agl.git] / meta-agl-core / recipes-graphics / wayland / agl-compositor_git.bb
1 SUMMARY = "Reference Wayland compositor for AGL"
2 DESCRIPTION = "The AGL compositor is a reference Wayland server for Automotive \
3 Grade Linux, using libweston as a base to provide a graphical environment for \
4 the automotive environment."
5
6 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/q/project:src%252Fagl-compositor"
7 SECTION = "x11"
8 LICENSE = "MIT"
9 LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
10
11 DEPENDS = "wayland wayland-protocols wayland-native weston \
12            ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
13
14 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
15 SRCREV = "4e4624dee9850b4a4e590dd0f0f2b3173bded085"
16 AGL_BRANCH:aglnext = "next"
17 SRCREV:aglnext = "${AUTOREV}"
18
19 PV = "0.0.10+git${SRCPV}"
20 S = "${WORKDIR}/git"
21
22 PACKAGECONFIG ?= ""
23 PACKAGECONFIG[policy-rba] = "-Dpolicy-default=rba,,librba,librba rba-config"
24 PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
25 PACKAGECONFIG[grpc-proxy] = "-Dgrpc-proxy=true,-Dgrpc-proxy=false,grpc grpc-native,grpc agl-shell-grpc-server"
26
27 inherit meson pkgconfig python3native
28
29 PACKAGES =+ "agl-shell-grpc-server"
30
31 FILES:${PN} = " \
32     ${bindir}/agl-compositor \
33     ${bindir}/agl-screenshooter \
34     ${libdir}/agl-compositor/libexec_compositor.so.0 \
35     ${libdir}/agl-compositor/libexec_compositor.so.0.0.21 \
36 "
37
38 FILES:agl-shell-grpc-server = " \
39     ${libdir}/agl-compositor/agl-shell-grpc-server \
40 "
41
42 RDEPENDS:${PN} += " \
43     agl-compositor-init \
44     xkeyboard-config \
45     ${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)} \
46     ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)} \
47 "
48
49 FILES:${PN}-dev += " \
50     ${datadir}/agl-compositor/protocols/agl-shell.xml \
51     ${datadir}/agl-compositor/protocols/agl-shell-desktop.xml \
52     ${libdir}/agl-compositor/libexec_compositor.so \
53 "