[Work-around] Update recipe for ImageMagick to avoid bitbake error
[AGL/meta-agl.git] / meta-agl-bsp / meta-rcar-gen3 / recipes-support / imagemagick / imagemagick_6.9.10.bb
1 SUMMARY = "ImageMagick is an image convertion tools"
2 SECTION = "console/utils"
3 LICENSE = "ImageMagick"
4 LIC_FILES_CHKSUM = "file://LICENSE;md5=4c223567f4c3b26a08c56aa59b346ca5"
5 # FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
6 DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib fftw freetype"
7
8 # Important note: tarballs for all patchsets within a version are deleted when
9 # a new pachset is created. To avoid multiple patches for each patchset, try to
10 # update to the last pachset of a version
11 PATCHSET = "10"
12 SRC_URI = "git://github.com/ImageMagick/ImageMagick6.git;protocol=https;tag=${PV}-${PATCHSET} \
13 "
14 S = "${WORKDIR}/git"
15
16 inherit autotools pkgconfig update-alternatives
17
18 # xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
19 # if someone needs xml support then fix it first
20 EXTRA_OECONF = "--program-prefix= --program-suffix=.im6 --without-perl --disable-openmp --without-xml --disable-opencl"
21
22 CACHED_CONFIGUREVARS = "ac_cv_sys_file_offset_bits=yes"
23 PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
24 PACKAGECONFIG[graphviz] = "--with-gvc,--without-gvc,graphviz"
25 PACKAGECONFIG[jp2] = "--with-jp2,,jasper"
26 PACKAGECONFIG[lzma] = "--with-lzma,--without-lzma,xz"
27 PACKAGECONFIG[openjpeg] = "--with-openjp2,--without-openjp2,openjpeg"
28 PACKAGECONFIG[pango] = "--with-pango,--without-pango,pango cairo"
29 PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp"
30 PACKAGECONFIG[wmf] = "--with-wmf,--without-wmf,libwmf"
31 PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 libxext libxt"
32
33 FILES_${PN} += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.so \
34                 ${libdir}/ImageMagick-${PV}/modules-Q16/*/*.la \
35                 ${libdir}/ImageMagick-${PV}/modules-Q16/filters \
36                 ${libdir}/ImageMagick-${PV}/modules-Q16/coders \
37                 ${libdir}/ImageMagick-${PV}/config-Q16 \
38                 ${datadir}/ImageMagick-6 "
39
40 FILES_${PN}-dev += "${libdir}/ImageMagick-${PV}/modules-Q16/*/*.a"
41
42 FILES_${PN}-dbg += "${libdir}/ImageMagick-${PV}/modules-Q16/*/.debug/*"
43
44 BBCLASSEXTEND = "native"
45
46 ALTERNATIVE_PRIORITY = "100"
47
48 ALTERNATIVE_${PN} = "animate compare composite conjure convert display \
49     identify import mogrify montage stream"
50
51 ALTERNATIVE_TARGET[animate] = "${bindir}/animate.im6"
52 ALTERNATIVE_TARGET[compare] = "${bindir}/compare.im6"
53 ALTERNATIVE_TARGET[composite] = "${bindir}/composite.im6"
54 ALTERNATIVE_TARGET[conjure] = "${bindir}/conjure.im6"
55 ALTERNATIVE_TARGET[convert] = "${bindir}/convert.im6"
56 ALTERNATIVE_TARGET[display] = "${bindir}/display.im6"
57 ALTERNATIVE_TARGET[identify] = "${bindir}/identify.im6"
58 ALTERNATIVE_TARGET[import] = "${bindir}/import.im6"
59 ALTERNATIVE_TARGET[mogrify] = "${bindir}/mogrify.im6"
60 ALTERNATIVE_TARGET[montage] = "${bindir}/montage.im6"
61 ALTERNATIVE_TARGET[stream] = "${bindir}/stream.im6"
62
63 ALTERNATIVE_${PN}-doc = "animate.1 compare.1 composite.1 conjure.1 \
64     convert.1 display.1 identify.1 import.1 mogrify.1 montage.1 stream.1"
65
66 ALTERNATIVE_LINK_NAME[animate.1] = "${mandir}/man1/animate.1"
67 ALTERNATIVE_TARGET[animate.1] = "${mandir}/man1/animate.im6.1"
68 ALTERNATIVE_LINK_NAME[compare.1] = "${mandir}/man1/compare.1"
69 ALTERNATIVE_TARGET[compare.1] = "${mandir}/man1/compare.im6.1"
70 ALTERNATIVE_LINK_NAME[composite.1] = "${mandir}/man1/composite.1"
71 ALTERNATIVE_TARGET[composite.1] = "${mandir}/man1/composite.im6.1"
72 ALTERNATIVE_LINK_NAME[conjure.1] = "${mandir}/man1/conjure.1"
73 ALTERNATIVE_TARGET[conjure.1] = "${mandir}/man1/conjure.im6.1"
74 ALTERNATIVE_LINK_NAME[convert.1] = "${mandir}/man1/convert.1"
75 ALTERNATIVE_TARGET[convert.1] = "${mandir}/man1/convert.im6.1"
76 ALTERNATIVE_LINK_NAME[display.1] = "${mandir}/man1/display.1"
77 ALTERNATIVE_TARGET[display.1] = "${mandir}/man1/display.im6.1"
78 ALTERNATIVE_LINK_NAME[identify.1] = "${mandir}/man1/identify.1"
79 ALTERNATIVE_TARGET[identify.1] = "${mandir}/man1/identify.im6.1"
80 ALTERNATIVE_LINK_NAME[import.1] = "${mandir}/man1/import.1"
81 ALTERNATIVE_TARGET[import.1] = "${mandir}/man1/import.im6.1"
82 ALTERNATIVE_LINK_NAME[mogrify.1] = "${mandir}/man1/mogrify.1"
83 ALTERNATIVE_TARGET[mogrify.1] = "${mandir}/man1/mogrify.im6.1"
84 ALTERNATIVE_LINK_NAME[montage.1] = "${mandir}/man1/montage.1"
85 ALTERNATIVE_TARGET[montage.1] = "${mandir}/man1/montage.im6.1"
86 ALTERNATIVE_LINK_NAME[stream.1] = "${mandir}/man1/stream.1"
87 ALTERNATIVE_TARGET[stream.1] = "${mandir}/man1/stream.im6.1"