add redraw_fixer, separate controller tool
[staging/windowmanager.git] / src / CMakeLists.txt
index f2c9b3a..f83aae2 100644 (file)
@@ -1,7 +1,7 @@
 wlproto(IVI_CON ivi-controller)
 
 include(FindPkgConfig)
-pkg_check_modules(AFB REQUIRED afb-daemon==1.0)
+pkg_check_modules(AFB REQUIRED afb-daemon)
 pkg_check_modules(SD REQUIRED libsystemd>=222)
 
 # We do not want a prefix for our module
@@ -18,7 +18,31 @@ add_library(winman MODULE
    wayland.hpp
    util.cpp
    util.hpp
-   ${IVI_CON_PROTO} json_helper.cpp json_helper.hpp app.hpp app.cpp result.hpp afb_binding_api.hpp afb_binding_glue.inl)
+   layout.cpp
+   layout.hpp
+   ${IVI_CON_PROTO}
+   json_helper.cpp
+   json_helper.hpp
+   app.hpp app.cpp
+   afb_binding_api.cpp
+   result.hpp
+   afb_binding_api.hpp
+   afb_binding_glue.inl
+   layers.cpp
+   layers.hpp
+   controller_hooks.hpp
+   config.cpp
+   config.hpp
+   policy.hpp)
+
+add_executable(redraw_fixer
+        redraw_fixer.cpp
+        ${IVI_CON_PROTO}
+        wayland.cpp
+        wayland.hpp
+        controller_hooks.hpp
+        util.cpp
+        util.hpp)
 
 target_include_directories(winman
     PRIVATE
@@ -27,6 +51,10 @@ target_include_directories(winman
         ../include
         ../src)
 
+target_link_libraries(redraw_fixer
+        PRIVATE
+        ${WLC_LIBRARIES})
+
 target_link_libraries(winman
     PRIVATE
         ${AFB_LIBRARIES}
@@ -41,10 +69,18 @@ target_compile_definitions(winman
         WINMAN_VERSION_STRING="${PACKAGE_VERSION}"
         _GNU_SOURCE)  # XXX should I define this here?!
 
+target_compile_definitions(redraw_fixer
+        PRIVATE
+        DO_NOT_USE_AFB   # override log* AFB macros
+        _GNU_SOURCE)
+
 if(NOT ${CMAKE_BUILD_TYPE} STREQUAL "Release")
    target_compile_definitions(winman
        PRIVATE
            _GLIBCXX_DEBUG)
+   target_compile_definitions(redraw_fixer
+           PRIVATE
+           _GLIBCXX_DEBUG)
 endif()
 
 target_compile_options(winman
@@ -53,7 +89,7 @@ target_compile_options(winman
 
 set_target_properties(winman
     PROPERTIES
-        INTERPROCEDURAL_OPTIMIZATION ON
+    # INTERPROCEDURAL_OPTIMIZATION ON
 
         CXX_EXTENSIONS OFF
         CXX_STANDARD 14
@@ -63,12 +99,15 @@ set_target_properties(winman
         C_STANDARD 99
         C_STANDARD_REQUIRED ON
 
-        LINK_FLAGS "-Wl,--version-script=../../export.map")
+        LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/../export.map")
 
 if (LINK_LIBCXX)
    set_target_properties(winman
            PROPERTIES
-           LINK_FLAGS "-Wl,--version-script=../../export.map -lc++")
+           LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/../export.map -lc++")
+   set_target_properties(redraw_fixer
+           PROPERTIES
+           LINK_FLAGS "-lc++")
 endif()
 
 if (NOT ${SANITIZER_MODE} STREQUAL "none" AND NOT ${SANITIZER_MODE} STREQUAL "")