Add sound manager initial source code
[staging/soundmanager.git] / soundmanager_binging / CMakeLists.txt
diff --git a/soundmanager_binging/CMakeLists.txt b/soundmanager_binging/CMakeLists.txt
new file mode 100644 (file)
index 0000000..003c394
--- /dev/null
@@ -0,0 +1,54 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+cmake_minimum_required(VERSION 3.0)
+
+set(TARGETS_SMBINDER soundmanager-binding)
+
+INCLUDE(FindThreads)
+FIND_PACKAGE(Threads)
+
+pkg_check_modules(sm_binding_depends afb-daemon glib-2.0 gio-2.0 gio-unix-2.0 json-c)
+set(binding_sm_sources 
+  soundmanager.c 
+  sm-helper.c 
+  dbus/audio_manager_interface.c)
+
+include_directories(dbus)
+link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
+
+add_library(${TARGETS_SMBINDER} MODULE ${binding_sm_sources})
+
+target_compile_options(${TARGETS_SMBINDER} PRIVATE ${sm_binding_depends_CFLAGS})
+if(DEFINED DEBUGMODE)
+ target_compile_options(${TARGETS_SMBINDER} PRIVATE -g -O0)
+else(DEFINED DEBUGMODE)
+ target_compile_options(${TARGETS_SMBINDER} PRIVATE -g -O2)
+endif(DEFINED DEBUGMODE)
+
+target_include_directories(${TARGETS_SMBINDER} PRIVATE ${sm_binding_depends_INCLUDE_DIRS})
+target_link_libraries(${TARGETS_SMBINDER} ${CMAKE_THREAD_LIBS_INIT} ${link_libraries} ${sm_binding_depends_LIBRARIES})
+
+# Binder exposes a unique public entry point
+
+set_target_properties(${TARGETS_SMBINDER} PROPERTIES
+    PREFIX ""
+    LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
+    )
+
+# installation directory
+INSTALL(TARGETS ${TARGETS_SMBINDER}
+    LIBRARY DESTINATION ${binding_install_dir})