Add sound manager initial source code
[staging/soundmanager.git] / libsoundmanager / CMakeLists.txt
diff --git a/libsoundmanager/CMakeLists.txt b/libsoundmanager/CMakeLists.txt
new file mode 100644 (file)
index 0000000..acf98de
--- /dev/null
@@ -0,0 +1,57 @@
+#
+# Copyright (c) 2017 TOYOTA MOTOR CORPORATION
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+
+cmake_minimum_required(VERSION 3.0)
+
+set(TARGET_LIBSM soundmanager)
+add_definitions("-std=c++11")
+
+pkg_check_modules(libsm_depends  json-c libafbwsc libsystemd audiomanager)
+set(libsm_sources libsoundmanager.cpp)
+
+include_directories(${LIBSM_INCLUDE_DIR})
+link_libraries(-Wl,--as-needed -Wl,--gc-sections -Wl,--no-undefined)
+
+add_library(${TARGET_LIBSM} SHARED ${libsm_sources})
+target_compile_options(${TARGET_LIBSM} PUBLIC ${libsm_depends_CFLAGS})
+
+if(DEFINED DEBUGMODE)
+ target_compile_options(${TARGET_LIBSM} PRIVATE -g -O0)
+else(DEFINED DEBUGMODE)
+ target_compile_options(${TARGET_LIBSM} PRIVATE -g -O2)
+endif(DEFINED DEBUGMODE)
+
+include_directories(${TARGET_LIBSM} ${libsm_depends_INCLUDE_DIRS})
+target_link_libraries(${TARGET_LIBSM} afbwsc -lpthread ${link_libraries} ${libsm_depends_LIBRARIES})
+
+INSTALL(TARGETS ${TARGET_LIBSM}
+    LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+
+#####################
+pkg_check_modules(test_depends glib-2.0 gio-2.0 gio-unix-2.0)
+add_executable(libsoundmanager-demo test.cpp)
+include_directories(libsoundmanager-demo ${test_depends_INCLUDE_DIRS})
+TARGET_LINK_LIBRARIES(libsoundmanager-demo
+    soundmanager
+    ${link_libraries}
+    -lpthread
+    ${test_depends_LIBRARIES}
+    ${libsm_depends_LIBRARIES}
+)
+#####################
+add_subdirectory(test)
+