test exec: remove git2go and cloning afb-helloworld
[src/xds/xds-server.git] / test / fixtures / helloworld / helloworld / CMakeLists.txt
diff --git a/test/fixtures/helloworld/helloworld/CMakeLists.txt b/test/fixtures/helloworld/helloworld/CMakeLists.txt
new file mode 100644 (file)
index 0000000..373a6f5
--- /dev/null
@@ -0,0 +1,36 @@
+###########################################################################
+# Copyright 2015, 2016, 2017 IoT.bzh
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+# Add target to project dependency list
+PROJECT_TARGET_ADD(helloworld)
+
+    # Define project Targets
+    file(GLOB sourcelist "*.c")
+
+    # Define project Targets
+    ADD_LIBRARY(${TARGET_NAME} MODULE ${sourcelist})
+
+    # Binder exposes a unique public entry point
+    SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+       PREFIX ""
+        LABELS "BINDING"
+       LINK_FLAGS  ${BINDINGS_LINK_FLAG}
+        OUTPUT_NAME ${TARGET_NAME}
+    )
+
+    TARGET_LINK_LIBRARIES(${TARGET_NAME}
+           ${link_libraries}
+    )