Removed incorrect setting for systemd service
[src/xds/xds-server.git] / conf.d / packaging / rpm / agl-xds-server.spec
index ee59be1..27d8d6b 100644 (file)
@@ -12,12 +12,14 @@ License:        Apache-2.0
 Summary:        XDS-server
 Url:            https://gerrit.automotivelinux.org/gerrit/p/src/xds/xds-server.git
 Source0:        xds-server_linux-amd64-%{version}.zip
+Source1:        rpmlintrc
 BuildRequires:  unzip
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 Group:          Development/Tools/Debuggers
 
 # for now still embedded with xds
-# Requires:       syncthing
+# Requires:       jq syncthing
+Requires:       jq
 
 %description
 xds-server is a web server that allows user to remotely cross build applications.
@@ -40,7 +42,6 @@ mkdir -p %{?buildroot}/%{_sysconfdir}/default
 cp ./conf.d/etc/default/xds-server %{?buildroot}/%{_sysconfdir}/default/
 mkdir -p %{?buildroot}/%{_sysconfdir}/xds/server
 cp ./conf.d/etc/xds/server/* %{?buildroot}/%{_sysconfdir}/xds/server/
-mkdir -p %{?buildroot}%{_userunitdir}/default.target.wants && ln -s ../xds-server.service %{?buildroot}%{_userunitdir}/default.target.wants/
 mkdir -p %{?buildroot}%{_sysconfdir}/profile.d
 sed -e "s;@XDS_INSTALL_BIN_DIR@;%{_bindir};g" ./conf.d/etc/profile.d/xds-server.sh > %{buildroot}%{_sysconfdir}/profile.d/%{name}.sh
 
@@ -61,8 +62,6 @@ sed -e "s;@XDS_INSTALL_BIN_DIR@;%{_bindir};g" ./conf.d/etc/profile.d/xds-server.
 %config %{_sysconfdir}/profile.d/%{name}.sh
 %dir %{_userunitdir}
 %{_userunitdir}/xds-server.service
-%dir %{_userunitdir}/default.target.wants
-%{_userunitdir}/default.target.wants/xds-server.service
 
 
 %post