Fix/Update packaging
[src/xds/xds-gdb.git] / conf.d / packaging / rpm / agl-xds-gdb.spec
index 178b77d..83bc2f7 100644 (file)
@@ -6,14 +6,15 @@
 %global debug_package %{nil}
 
 Name:           agl-xds-gdb
-Version:        1.0.2
+Version:        0.0.0
 Release:        0
 License:        Apache-2.0
 Summary:        Wrapper on gdb debugger for XDS
-Url:            https://github.com/iotbzh/xds-gdb.git
-Source0:        xds-gdb_linux-amd64-v1.0.2_2018-04-05_131503.zip
+Url:            https://gerrit.automotivelinux.org/gerrit/p/src/xds/xds-gdb.git
+Source0:        xds-gdb_linux-amd64-%{version}.zip
 BuildRequires:  unzip
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
+Group:          Development/Tools/Debuggers
 
 %description
 xds-gdb is an agent that should run on your local machine when you use XDS
@@ -27,6 +28,7 @@ xds-gdb is an agent that should run on your local machine when you use XDS
 mkdir -p %{?buildroot}%{_prefix}/xds/gdb %{?buildroot}%{_bindir}
 cp xds-gdb %{?buildroot}%{_prefix}/xds/gdb
 ln -s ../xds/gdb/xds-gdb %{?buildroot}%{_bindir}/xds-gdb
+
 mkdir -p %{?buildroot}%{_sysconfdir}/profile.d
 sed -e "s;@XDS_INSTALL_BIN_DIR@;%{_bindir};g" ./conf.d/etc/profile.d/xds-gdb.sh > %{buildroot}%{_sysconfdir}/profile.d/%{name}.sh
 
@@ -37,5 +39,6 @@ sed -e "s;@XDS_INSTALL_BIN_DIR@;%{_bindir};g" ./conf.d/etc/profile.d/xds-gdb.sh
 %dir %{_prefix}/xds
 %dir %{_prefix}/xds/gdb
 %{_prefix}/xds/gdb/*
-%{_prefix}/bin/xds-gdb
+%{_bindir}/xds-gdb
 %config %{_sysconfdir}/profile.d/%{name}.sh
+%attr(644,root,root) %{_sysconfdir}/profile.d/%{name}.sh