Allow setting of libexec location
[src/app-framework-main.git] / src / CMakeLists.txt
index f30ca38..8f081ee 100644 (file)
@@ -1,5 +1,5 @@
 ###########################################################################
-# Copyright (C) 2015-2018 IoT.bzh
+# Copyright (C) 2015-2019 IoT.bzh
 #
 # author: José Bollo <jose.bollo@iot.bzh>
 #
@@ -180,7 +180,7 @@ if(libsystemd_FOUND AND AFB_FOUND)
                PREFIX ""
                LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/afm-binding.export-map"
        )
-       install(TARGETS afm-binding LIBRARY DESTINATION ${CMAKE_INSTALL_LIBEXECDIR}/afm)
+       install(TARGETS afm-binding LIBRARY DESTINATION ${afm_libexecdir})
 
        add_executable(afm-user-session afm-user-session.c)
        install(TARGETS afm-user-session DESTINATION ${CMAKE_INSTALL_BINDIR}