afm-user-daemon: Remove it by default
[src/app-framework-main.git] / conf / user / CMakeLists.txt
index 714a962..a8d72dc 100644 (file)
@@ -1,5 +1,5 @@
 ###########################################################################
-# Copyright 2015, 2016, 2017 IoT.bzh
+# Copyright (C) 2015-2019 IoT.bzh
 #
 # author: José Bollo <jose.bollo@iot.bzh>
 #
@@ -18,9 +18,9 @@
 
 cmake_minimum_required(VERSION 2.8)
 
-configure_file(afm-user-daemon.service.in afm-user-daemon.service)
+if(NOT USE_SDK AND LEGACY_USER_DAEMON)
+       configure_file(afm-user-daemon.service.in afm-user-daemon.service)
 
-if(NOT USE_SDK)
        set(SYSCONFDIR_DBUS_USER   ${CMAKE_INSTALL_SYSCONFDIR}/dbus-1/session.d CACHE STRING "Path to dbus session configuration files")
        set(UNITDIR_USER           ${CMAKE_INSTALL_LIBDIR}/systemd/user CACHE STRING "Path to systemd system unit files")