Fix synchronisation of user setup
[src/app-framework-main.git] / conf / system / CMakeLists.txt
index eba8d42..3cabd0c 100644 (file)
 
 cmake_minimum_required(VERSION 2.8)
 
+if(AGL_DEVEL)
+  set(create_platform_debug "dodir ${afm_platform_rundir}/debug")
+endif()
+
 configure_file(afm-system-daemon.service.in afm-system-daemon.service)
 configure_file(afm-system-daemon.socket.in  afm-system-daemon.socket)
 configure_file(afm-system-setup.service.in  afm-system-setup.service)
@@ -46,6 +50,12 @@ if(NOT USE_SDK)
                DESTINATION
                        ${UNITDIR_SYSTEM}
        )
+       install(
+               DIRECTORY
+                       ${CMAKE_CURRENT_SOURCE_DIR}/user-runtime-dir@.service.wants
+               DESTINATION
+                       ${UNITDIR_SYSTEM}
+       )
        install(
                PROGRAMS
                        ${CMAKE_CURRENT_BINARY_DIR}/afm-user-setup.sh