afb-session: Refactor and test unit
[src/app-framework-binder.git] / src / tests / session / CMakeLists.txt
diff --git a/src/tests/session/CMakeLists.txt b/src/tests/session/CMakeLists.txt
new file mode 100644 (file)
index 0000000..91b9973
--- /dev/null
@@ -0,0 +1,23 @@
+###########################################################################
+# Copyright 2017 IoT.bzh
+#
+# author: José Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+add_executable(test-session test-session.c)
+target_include_directories(test-session PRIVATE ../..)
+target_link_libraries(test-session afb-lib ${link_libraries})
+add_test(NAME session COMMAND test-session)
+