Update copyright dates
[src/app-framework-binder.git] / src / tests / CMakeLists.txt
index 774f59a..46aec88 100644 (file)
@@ -1,5 +1,5 @@
 ###########################################################################
-# Copyright 2017 IoT.bzh
+# Copyright (C) 2015-2020 "IoT.bzh"
 #
 # author: José Bollo <jose.bollo@iot.bzh>
 #
 ###########################################################################
 
 
+PKG_CHECK_MODULES(check check)
+if(check_FOUND)
+       INCLUDE_DIRECTORIES(${INCLUDE_DIRS} ${check_INCLUDE_DIRS})
+       SET(link_libraries ${link_libraries} ${check_LDFLAGS})
+       add_subdirectory(session)
+       add_subdirectory(apiset)
+       add_subdirectory(apiv3)
+       add_subdirectory(wrap-json)
+       add_subdirectory(globset)
+       add_subdirectory(u16id)
+else(check_FOUND)
+       MESSAGE(WARNING "check not found! no test!")
+endif(check_FOUND)