improves versionning of libafbwsc
[src/app-framework-binder.git] / src / CMakeLists.txt
index f41a3a8..ca20665 100644 (file)
@@ -73,6 +73,9 @@ INSTALL(TARGETS afb-daemon
 # build and install libafbwsc
 ###########################################
 ADD_LIBRARY(afbwsc SHARED afb-ws.c afb-ws-client.c afb-wsj1.c websock.c afb-common.c)
+SET_TARGET_PROPERTIES(afbwsc PROPERTIES
+       VERSION ${LIBAFBWSC_VERSION}
+       SOVERSION ${LIBAFBWSC_SOVERSION})
 TARGET_LINK_LIBRARIES(afbwsc
        ${libsystemd_LIBRARIES}
        -Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export-afbwsc.map