u16id: Add maps for identifiers id of 16 bits
[src/app-framework-binder.git] / src / CMakeLists.txt
index ee0adb4..abfd13e 100644 (file)
@@ -26,12 +26,12 @@ ADD_DEFINITIONS(-DINFER_EXTENSION)
 
 ############################################################################
 # TODO: improve below setting by using config file
-option(WITH_SIG_MONITOR_DUMPSTACK "activate dump stack on error"           ON)
-option(WITH_SIG_MONITOR_SIGNALS   "activate handling of signals"           ON)
-option(WITH_SIG_MONITOR_FOR_CALL  "activate monitoring of calls"           ON)
-option(WITH_SIG_MONITOR_TIMERS    "activate monitoring of call expiration" ON)
-option(WITH_AFB_HOOK              "include hooking"                        ON)
-option(WITH_AFB_TRACE             "include monitoring trace"               ON)
+option(WITH_SIG_MONITOR_DUMPSTACK "Activate dump stack on error"           ON)
+option(WITH_SIG_MONITOR_SIGNALS   "Activate handling of signals"           ON)
+option(WITH_SIG_MONITOR_FOR_CALL  "Activate monitoring of calls"           ON)
+option(WITH_SIG_MONITOR_TIMERS    "Activate monitoring of call expiration" ON)
+option(WITH_AFB_HOOK              "Include hooking"                        ON)
+option(WITH_AFB_TRACE             "Include monitoring trace"               ON)
 option(WITH_SUPERVISOR            "Activates installation of supervisor"   OFF)
 option(WITH_DBUS_TRANSPARENCY     "Allows API transparency over DBUS"      OFF)
 option(WITH_LEGACY_BINDING_V1     "Includes the legacy Binding API version 1" OFF)
@@ -104,6 +104,7 @@ SET(AFB_LIB_SOURCES
        afb-socket.c
        afb-stub-ws.c
        afb-supervision.c
+       afb-token.c
        afb-trace.c
        afb-websock.c
        afb-ws-client.c
@@ -123,6 +124,7 @@ SET(AFB_LIB_SOURCES
        sig-monitor.c
        subpath.c
        systemd.c
+       u16id.c
        uuid.c
        verbose.c
        watchdog.c