sig-monitor: Add compiling switches
[src/app-framework-binder.git] / src / CMakeLists.txt
index c457d23..1d5da5e 100644 (file)
@@ -1,5 +1,5 @@
 ###########################################################################
-# Copyright (C) 2015-2018 "IoT.bzh"
+# Copyright (C) 2015-2019 "IoT.bzh"
 #
 # author: José Bollo <jose.bollo@iot.bzh>
 #
@@ -24,6 +24,35 @@ ADD_DEFINITIONS(-DBINDING_INSTALL_DIR="${binding_install_dir}")
 # Always add INFER_EXTENSION (more details in afb-hreq.c)
 ADD_DEFINITIONS(-DINFER_EXTENSION)
 
+############################################################################
+# TODO: improve below setting
+set(USE_SIG_MONITOR_DUMPSTACK ON CACHE BOOL "activate dump stack on error")
+set(USE_SIG_MONITOR_SIGNALS   ON CACHE BOOL "activate handling of signals")
+set(USE_SIG_MONITOR_FOR_CALL  ON CACHE BOOL "activate monitoring of calls")
+set(USE_SIG_MONITOR_TIMERS    ON CACHE BOOL "activate monitoring of call expiration")
+
+if(USE_SIG_MONITOR_DUMPSTACK)
+  add_definitions(-DUSE_SIG_MONITOR_DUMPSTACK=1)
+else()
+  add_definitions(-DUSE_SIG_MONITOR_DUMPSTACK=0)
+endif()
+if(USE_SIG_MONITOR_SIGNALS)
+  add_definitions(-DUSE_SIG_MONITOR_SIGNALS=1)
+else()
+  add_definitions(-DUSE_SIG_MONITOR_SIGNALS=0)
+endif()
+if(USE_SIG_MONITOR_FOR_CALL)
+  add_definitions(-DUSE_SIG_MONITOR_FOR_CALL=1)
+else()
+  add_definitions(-DUSE_SIG_MONITOR_FOR_CALL=0)
+endif()
+if(USE_SIG_MONITOR_TIMERS)
+  add_definitions(-DUSE_SIG_MONITOR_TIMERS=1)
+else()
+  add_definitions(-DUSE_SIG_MONITOR_TIMERS=0)
+endif()
+############################################################################
+
 SET(AFB_LIB_SOURCES
        afb-api.c
        afb-api-so.c
@@ -45,6 +74,7 @@ SET(AFB_LIB_SOURCES
        afb-export.c
        afb-fdev.c
        afb-hook.c
+       afb-hook-flags.c
        afb-hreq.c
        afb-hsrv.c
        afb-hswitch.c
@@ -53,8 +83,8 @@ SET(AFB_LIB_SOURCES
        afb-msg-json.c
        afb-proto-ws.c
        afb-session.c
+       afb-socket.c
        afb-stub-ws.c
-       afb-systemd.c
        afb-trace.c
        afb-websock.c
        afb-ws-client.c
@@ -62,16 +92,20 @@ SET(AFB_LIB_SOURCES
        afb-ws.c
        afb-wsj1.c
        afb-xreq.c
+       evmgr.c
        fdev.c
        fdev-epoll.c
        fdev-systemd.c
+       globset.c
        jobs.c
        locale-root.c
        pearson.c
        process-name.c
        sig-monitor.c
        subpath.c
+       systemd.c
        verbose.c
+       watchdog.c
        websock.c
        wrap-json.c
 )
@@ -123,7 +157,7 @@ ENDIF()
 ###########################################
 # build and install libafbwsc
 ###########################################
-ADD_LIBRARY(afbwsc SHARED afb-ws.c afb-ws-client.c afb-wsj1.c websock.c afb-proto-ws.c jobs-fake.c fdev.c fdev-systemd.c)
+ADD_LIBRARY(afbwsc SHARED afb-ws.c afb-ws-client.c afb-wsj1.c websock.c afb-proto-ws.c fdev.c fdev-systemd.c verbose.c)
 SET_TARGET_PROPERTIES(afbwsc PROPERTIES
        VERSION ${LIBAFBWSC_VERSION}
        SOVERSION ${LIBAFBWSC_SOVERSION})