Introduce object for tokens
[src/app-framework-binder.git] / src / CMakeLists.txt
index 71cd1ff..0d5e712 100644 (file)
@@ -20,18 +20,18 @@ if (CMAKE_C_COMPILER_VERSION VERSION_LESS 4.9)
     message(FATAL_ERROR "Require at least gcc-4.9")
 endif(CMAKE_C_COMPILER_VERSION VERSION_LESS 4.9)
 
-ADD_DEFINITIONS(-DBINDING_INSTALL_DIR="${binding_install_dir}")
+ADD_DEFINITIONS(-DINTRINSIC_BINDING_DIR="${INTRINSIC_BINDING_DIR}")
 # Always add INFER_EXTENSION (more details in afb-hreq.c)
 ADD_DEFINITIONS(-DINFER_EXTENSION)
 
 ############################################################################
 # TODO: improve below setting by using config file
-option(WITH_SIG_MONITOR_DUMPSTACK "activate dump stack on error"           ON)
-option(WITH_SIG_MONITOR_SIGNALS   "activate handling of signals"           ON)
-option(WITH_SIG_MONITOR_FOR_CALL  "activate monitoring of calls"           ON)
-option(WITH_SIG_MONITOR_TIMERS    "activate monitoring of call expiration" ON)
-option(WITH_AFB_HOOK              "include hooking"                        ON)
-option(WITH_AFB_TRACE             "include monitoring trace"               ON)
+option(WITH_SIG_MONITOR_DUMPSTACK "Activate dump stack on error"           ON)
+option(WITH_SIG_MONITOR_SIGNALS   "Activate handling of signals"           ON)
+option(WITH_SIG_MONITOR_FOR_CALL  "Activate monitoring of calls"           ON)
+option(WITH_SIG_MONITOR_TIMERS    "Activate monitoring of call expiration" ON)
+option(WITH_AFB_HOOK              "Include hooking"                        ON)
+option(WITH_AFB_TRACE             "Include monitoring trace"               ON)
 option(WITH_SUPERVISOR            "Activates installation of supervisor"   OFF)
 option(WITH_DBUS_TRANSPARENCY     "Allows API transparency over DBUS"      OFF)
 option(WITH_LEGACY_BINDING_V1     "Includes the legacy Binding API version 1" OFF)
@@ -104,6 +104,7 @@ SET(AFB_LIB_SOURCES
        afb-socket.c
        afb-stub-ws.c
        afb-supervision.c
+       afb-token.c
        afb-trace.c
        afb-websock.c
        afb-ws-client.c
@@ -123,6 +124,7 @@ SET(AFB_LIB_SOURCES
        sig-monitor.c
        subpath.c
        systemd.c
+       uuid.c
        verbose.c
        watchdog.c
        websock.c