Fix false ***buffer overflow*** detection
[src/app-framework-binder.git] / conf.d / packaging / rpm / agl-app-framework-binder.spec
index 94de1c7..e41fd96 100644 (file)
@@ -16,7 +16,7 @@ Group:          Development/Libraries/C and C++
 Url:            https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder
 Source:         app-framework-binder-%{version}.tar.gz
 #BuildRequires:  gdb
-BuildRequires:  pkgconfig(libmicrohttpd) >= 0.9.62
+BuildRequires:  pkgconfig(libmicrohttpd) >= 0.9.60
 BuildRequires:  make
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(libsystemd) >= 222
@@ -28,7 +28,13 @@ BuildRequires:  pkgconfig(json-c)
 BuildRequires:  file-devel
 BuildRequires:  gcc-c++
 
-Requires:       libmicrohttpd >= 0.9.62
+%if 0%{?suse_version}
+Requires:       libmicrohttpd12 >= 0.9.60
+%endif
+
+%if 0%{?fedora_version}
+Requires:       libmicrohttpd >= 0.9.60
+%endif
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 
@@ -51,7 +57,7 @@ This service is evolving permanently and is only designed as a helper for develo
 
 %build
 export PKG_CONFIG_PATH=%{_libdir}/pkgconfig
-%cmake  -DAGL_DEVEL=1 -DINCLUDE_MONITORING=ON
+%cmake  -DAGL_DEVEL=1 -DINCLUDE_MONITORING=ON"
 %__make %{?_smp_mflags}