Fedora 30 packaging fix issu
[src/app-framework-binder.git] / conf.d / packaging / rpm / agl-app-framework-binder.spec
index 5f3bcbd..bfe1315 100644 (file)
@@ -16,7 +16,7 @@ Group:          Development/Libraries/C and C++
 Url:            https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder
 Source:         app-framework-binder-%{version}.tar.gz
 #BuildRequires:  gdb
-BuildRequires:  pkgconfig(libmicrohttpd) >= 0.9.55
+BuildRequires:  pkgconfig(libmicrohttpd) >= 0.9.62
 BuildRequires:  make
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(libsystemd) >= 222
@@ -28,6 +28,14 @@ BuildRequires:  pkgconfig(json-c)
 BuildRequires:  file-devel
 BuildRequires:  gcc-c++
 
+%if 0%{?suse_version}
+Requires:       libmicrohttpd12 >= 0.9.60
+%endif
+
+%if 0%{?fedora_version}
+Requires:       libmicrohttpd >= 0.9.60
+%endif
+
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -49,7 +57,7 @@ This service is evolving permanently and is only designed as a helper for develo
 
 %build
 export PKG_CONFIG_PATH=%{_libdir}/pkgconfig
-%cmake  -DAGL_DEVEL=1 -DINCLUDE_MONITORING=ON
+%cmake  -DAGL_DEVEL=1 -DINCLUDE_MONITORING=ON" CFLAGS='-O2 -g -pipe -Wall-Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection'
 %__make %{?_smp_mflags}
 
 
@@ -58,7 +66,7 @@ export PKG_CONFIG_PATH=%{_libdir}/pkgconfig
 %make_install
 
 mkdir -p %{buildroot}%{_sysconfdir}/profile.d
-cat << EOF > %{buildroot}%{_sysconfdir}/profile.d/AGL-%{name}.sh
+cat << EOF > %{buildroot}%{_sysconfdir}/profile.d/%{name}.sh
 #----------  AGL %%{name} options Start ---------"
 # Object: AGL cmake option for  binder/bindings
 export LD_LIBRARY_PATH=%{_libdir}:\${LD_LIBRARY_PATH}
@@ -83,20 +91,12 @@ EOF
 
 %dir %{_libdir}
 %dir %{_libdir}/afb
-%{_libdir}/afb/afb-dbus-binding.so
-%{_libdir}/afb/authLogin.so
 %{_libdir}/libafbwsc.so.1
 %{_libdir}/libafbwsc.so.1.1
 
 #app-framework-binder demo
-%{_libdir}/afb/demoContext.so
-%{_libdir}/afb/demoPost.so
-%{_libdir}/afb/helloWorld.so
-%{_libdir}/afb/tic-tac-toe.so
-%{_libdir}/afb/ave.so
-%{_libdir}/afb/hello3.so
-%{_libdir}/afb/hi3.so
-%config(noreplace) %{_sysconfdir}/profile.d/AGL-%{name}.sh
+%{_libdir}/afb/*.so
+%config(noreplace) %{_sysconfdir}/profile.d/%{name}.sh
 
 #app-framework-binder monitoring
 %dir %{_libdir}/afb/monitoring
@@ -108,9 +108,7 @@ EOF
 %{_libdir}/libafbwsc.so
 %dir %{_includedir}
 %dir %{_includedir}/afb
-%{_includedir}/afb/*.h
-%{_includedir}/afb/*.hpp
-%{_includedir}/afb/afb-binding
+%{_includedir}/afb/*
 %dir %{_libdir}/pkgconfig
 %{_libdir}/pkgconfig/*.pc