Change agl-app-framework-binder.sh
[src/app-framework-binder.git] / conf.d / packaging / rpm / agl-app-framework-binder.spec
index bf4e9b5..b947ee5 100644 (file)
@@ -16,7 +16,7 @@ Group:          Development/Libraries/C and C++
 Url:            https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder
 Source:         app-framework-binder-%{version}.tar.gz
 #BuildRequires:  gdb
-BuildRequires:  pkgconfig(libmicrohttpd) >= 0.9.55
+BuildRequires:  pkgconfig(libmicrohttpd) >= 0.9.60
 BuildRequires:  make
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(libsystemd) >= 222
@@ -28,6 +28,14 @@ BuildRequires:  pkgconfig(json-c)
 BuildRequires:  file-devel
 BuildRequires:  gcc-c++
 
+%if 0%{?suse_version}
+Requires:       libmicrohttpd12 >= 0.9.60
+%endif
+
+%if 0%{?fedora_version}
+Requires:       libmicrohttpd >= 0.9.60
+%endif
+
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -49,7 +57,7 @@ This service is evolving permanently and is only designed as a helper for develo
 
 %build
 export PKG_CONFIG_PATH=%{_libdir}/pkgconfig
-%cmake  -DAGL_DEVEL=1 -DINCLUDE_MONITORING=ON
+%cmake  -DAGL_DEVEL=1 -DINCLUDE_MONITORING=ON"
 %__make %{?_smp_mflags}
 
 
@@ -88,7 +96,7 @@ EOF
 
 #app-framework-binder demo
 %{_libdir}/afb/*.so
-%config(noreplace) %{_sysconfdir}/profile.d/AGL-%{name}.sh
+%config(noreplace) %{_sysconfdir}/profile.d/%{name}.sh
 
 #app-framework-binder monitoring
 %dir %{_libdir}/afb/monitoring