Reordering of sample and tutorial bindings
[src/app-framework-binder.git] / conf.d / packaging / rpm / agl-app-framework-binder.spec
index 94de1c7..7102e86 100644 (file)
@@ -16,7 +16,7 @@ Group:          Development/Libraries/C and C++
 Url:            https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder
 Source:         app-framework-binder-%{version}.tar.gz
 #BuildRequires:  gdb
-BuildRequires:  pkgconfig(libmicrohttpd) >= 0.9.62
+BuildRequires:  pkgconfig(libmicrohttpd) >= 0.9.60
 BuildRequires:  make
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(libsystemd) >= 222
@@ -28,7 +28,13 @@ BuildRequires:  pkgconfig(json-c)
 BuildRequires:  file-devel
 BuildRequires:  gcc-c++
 
-Requires:       libmicrohttpd >= 0.9.62
+%if 0%{?suse_version}
+Requires:       libmicrohttpd12 >= 0.9.60
+%endif
+
+%if 0%{?fedora_version}
+Requires:       libmicrohttpd >= 0.9.60
+%endif
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 
@@ -45,6 +51,12 @@ Summary:        AGL app-framework-binder-devel
 Provides a test agl binder service which can be used to test agl bindings on Linux PC
 This service is evolving permanently and is only designed as a helper for developper.
 
+%package samples
+Requires:       %{name} = %{version}
+Summary:        AGL app-framework-binder-samples
+%description samples
+Provides sample bindings for testing AGL framework binder
+
 
 %prep
 %setup -q -n app-framework-binder-%{version}
@@ -60,7 +72,7 @@ export PKG_CONFIG_PATH=%{_libdir}/pkgconfig
 %make_install
 
 mkdir -p %{buildroot}%{_sysconfdir}/profile.d
-cat << EOF > %{buildroot}%{_sysconfdir}/profile.d/AGL-%{name}.sh
+cat << EOF > %{buildroot}%{_sysconfdir}/profile.d/%{name}.sh
 #----------  AGL %%{name} options Start ---------"
 # Object: AGL cmake option for  binder/bindings
 export LD_LIBRARY_PATH=%{_libdir}:\${LD_LIBRARY_PATH}
@@ -90,7 +102,7 @@ EOF
 
 #app-framework-binder demo
 %{_libdir}/afb/*.so
-%config(noreplace) %{_sysconfdir}/profile.d/AGL-%{name}.sh
+%config(noreplace) %{_sysconfdir}/profile.d/%{name}.sh
 
 #app-framework-binder monitoring
 %dir %{_libdir}/afb/monitoring
@@ -106,6 +118,12 @@ EOF
 %dir %{_libdir}/pkgconfig
 %{_libdir}/pkgconfig/*.pc
 
+%files samples
+%defattr(-,root,root)
+%dir %{_datadir}
+%dir %{_datadir}/af-binder
+%{_datadir}/af-binder/*
+
 %changelog
 * Wed Sep 27 2017 Dominig
 - move to git repo