Fix rpm packaging following review 20926
[src/app-framework-binder.git] / conf.d / packaging / rpm / agl-app-framework-binder.spec
index dbdb898..4f70146 100644 (file)
@@ -28,7 +28,13 @@ BuildRequires:  pkgconfig(json-c)
 BuildRequires:  file-devel
 BuildRequires:  gcc-c++
 
+%if 0%{?suse_version}
+Requires:       libmicrohttpd12 >= 0.9.60
+%endif
+
+%if 0%{?fedora_version}
 Requires:       libmicrohttpd >= 0.9.60
+%endif
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 
@@ -51,7 +57,7 @@ This service is evolving permanently and is only designed as a helper for develo
 
 %build
 export PKG_CONFIG_PATH=%{_libdir}/pkgconfig
-%cmake  -DAGL_DEVEL=1 -DINCLUDE_MONITORING=ON
+%cmake  -DAGL_DEVEL=1 -DINCLUDE_MONITORING=ON"
 %__make %{?_smp_mflags}
 
 
@@ -60,7 +66,7 @@ export PKG_CONFIG_PATH=%{_libdir}/pkgconfig
 %make_install
 
 mkdir -p %{buildroot}%{_sysconfdir}/profile.d
-cat << EOF > %{buildroot}%{_sysconfdir}/profile.d/AGL-%{name}.sh
+cat << EOF > %{buildroot}%{_sysconfdir}/profile.d/%{name}.sh
 #----------  AGL %%{name} options Start ---------"
 # Object: AGL cmake option for  binder/bindings
 export LD_LIBRARY_PATH=%{_libdir}:\${LD_LIBRARY_PATH}
@@ -90,7 +96,7 @@ EOF
 
 #app-framework-binder demo
 %{_libdir}/afb/*.so
-%config(noreplace) %{_sysconfdir}/profile.d/AGL-%{name}.sh
+%config(noreplace) %{_sysconfdir}/profile.d/%{name}.sh
 
 #app-framework-binder monitoring
 %dir %{_libdir}/afb/monitoring