Update copyright dates
[src/app-framework-binder.git] / bindings / intrinsics / CMakeLists.txt
index c6ff8ef..9822122 100644 (file)
@@ -1,3 +1,21 @@
+###########################################################################
+# Copyright (C) 2015-2020 "IoT.bzh"
+#
+# author: José Bollo <jose.bollo@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
 
 INCLUDE_DIRECTORIES(${include_dirs})
 
@@ -9,7 +27,7 @@ SET_TARGET_PROPERTIES(afb-dbus-binding PROPERTIES
        PREFIX ""
        LINK_FLAGS "-Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/export.map"
 )
-TARGET_LINK_LIBRARIES(afb-dbus-binding ${link_libraries})
+TARGET_LINK_LIBRARIES(afb-dbus-binding ${json-c_LDFLAGS} ${libsystemd_LDFLAGS})
 INSTALL(TARGETS afb-dbus-binding
-        LIBRARY DESTINATION ${binding_install_dir})
+        LIBRARY DESTINATION ${INTRINSIC_BINDING_DIR})