Add tests for data persistence binding
[apps/agl-service-data-persistence.git] / test / tests / CMakeLists.txt
diff --git a/test/tests/CMakeLists.txt b/test/tests/CMakeLists.txt
new file mode 100644 (file)
index 0000000..c03658a
--- /dev/null
@@ -0,0 +1,31 @@
+###########################################################################
+# Copyright 2018 IoT.bzh
+#
+# author:Frédéric Marec <frederic.marec@iot.bzh>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+###########################################################################
+
+
+##################################################
+# Data persistence Lua Scripts
+##################################################
+PROJECT_TARGET_ADD(test-files)
+
+       file(GLOB LUA_FILES "*.lua")
+       add_input_files("${LUA_FILES}")
+
+       SET_TARGET_PROPERTIES(${TARGET_NAME} PROPERTIES
+       LABELS "TEST-DATA"
+       OUTPUT_NAME ${TARGET_NAME}
+       )
\ No newline at end of file