Introduce TI DRA7 vayu and cleanup template files 27/5527/3
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Wed, 13 Apr 2016 22:32:42 +0000 (00:32 +0200)
committerGerrit Code Review <gerrit@172.30.200.200>
Sun, 1 May 2016 21:38:46 +0000 (21:38 +0000)
This changeset introduces the TI 'vayu' board.
We need to adapt the provided bsp layer 'meta-ti' as
it is only at YP 1.8 fido right now.
Two changes are needed/known:
a) BBMASK eudev bbappend (local.conf.sample)
b) apply patch for gcc5 to u-boot-ti-staging

On top thie changeset also does janitorial work on the templates:
- conf-notes is now in a folder common and symlinked
- layer additions have been sync'ed
- file layout sync'ed with templates in meta-agl-demo

Change-Id: Ib52a9252800d54d5105ac1f5354ad3a3b014188f
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
21 files changed:
meta-agl-bsp/recipes-bsp/u-boot/files/fix_builderror_gcc5.patch [new file with mode: 0644]
meta-agl-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2015.07.bbappend [new file with mode: 0644]
meta-agl/conf/distro/poky-agl-sysvinit.conf
meta-agl/conf/distro/poky-agl.conf
scripts/envsetup.sh
templates/common/conf-notes.txt [new file with mode: 0644]
templates/dra7xx-evm/conf/bblayers.conf.sample [new file with mode: 0644]
templates/dra7xx-evm/conf/conf-notes.txt [new symlink]
templates/dra7xx-evm/conf/local.conf.sample [new file with mode: 0644]
templates/intel-corei7-64/conf/bblayers.conf.sample
templates/intel-corei7-64/conf/conf-notes.txt [changed from file to symlink]
templates/intel-corei7-64/conf/local.conf.sample
templates/qemux86-64/conf/bblayers.conf.sample
templates/qemux86-64/conf/conf-notes.txt [changed from file to symlink]
templates/qemux86-64/conf/local.conf.sample
templates/qemux86/conf/bblayers.conf.sample
templates/qemux86/conf/conf-notes.txt [changed from file to symlink]
templates/qemux86/conf/local.conf.sample
templates/wandboard/conf/bblayers.conf.sample
templates/wandboard/conf/conf-notes.txt [changed from file to symlink]
templates/wandboard/conf/local.conf.sample

diff --git a/meta-agl-bsp/recipes-bsp/u-boot/files/fix_builderror_gcc5.patch b/meta-agl-bsp/recipes-bsp/u-boot/files/fix_builderror_gcc5.patch
new file mode 100644 (file)
index 0000000..c462191
--- /dev/null
@@ -0,0 +1,26 @@
+Fix the following build break:
+
+drivers/usb/host/xhci-omap.c:35:5: error: ‘board_usb_init’ aliased to external symbol ‘__board_usb_init’
+ int board_usb_init(int index, enum usb_init_type init)
+      ^
+
+Signed-off-by: Felipe Balbi <balbi at ti.com>
+---
+ drivers/usb/host/xhci-omap.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/usb/host/xhci-omap.c b/drivers/usb/host/xhci-omap.c
+index 104e7a7282cf..fd19f79f0fc5 100644
+--- a/drivers/usb/host/xhci-omap.c
++++ b/drivers/usb/host/xhci-omap.c
+@@ -27,7 +27,7 @@ DECLARE_GLOBAL_DATA_PTR;
+ static struct omap_xhci omap;
+-inline int __board_usb_init(int index, enum usb_init_type init)
++__weak int __board_usb_init(int index, enum usb_init_type init)
+ {
+    return 0;
+ }
+--
+2.5.3
\ No newline at end of file
diff --git a/meta-agl-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2015.07.bbappend b/meta-agl-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2015.07.bbappend
new file mode 100644 (file)
index 0000000..50050ab
--- /dev/null
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# This applies to the JACINTO 6 vayu board ... essentially it is dra7_evm.
+SRC_URI_vayu     += "file://fix_builderror_gcc5.patch"
index 71a4192..e6b2262 100644 (file)
@@ -131,3 +131,7 @@ ERROR_QA = "dev-so debug-deps dev-deps debug-files arch pkgconfig la perms \
             compile-host-path dep-cmp installed-vs-shipped install-host-path \
             packages-list perm-config perm-line perm-link pkgv-undefined \
             pn-overrides split-strip var-undefined version-going-backwards"
+
+# using multiple BSP layers causes dangling bbappends in meta-agl-bsp
+# turn it into a warning
+BB_DANGLINGAPPENDS_WARNONLY = "1"
\ No newline at end of file
index 1be2a96..3c3903b 100644 (file)
@@ -130,3 +130,7 @@ WARN_TO_ERROR_QA = "already-stripped compile-host-path install-host-path \
                     useless-rpaths"
 WARN_QA_remove = "${WARN_TO_ERROR_QA}"
 ERROR_QA_append = " ${WARN_TO_ERROR_QA}"
+
+# using multiple BSP layers causes dangling bbappends in meta-agl-bsp
+# turn it into a warning
+BB_DANGLINGAPPENDS_WARNONLY = "1"
\ No newline at end of file
index 6ca10de..8506954 100644 (file)
@@ -6,7 +6,7 @@ if [ -z $1 ]; then
 fi
 
 MACHINE="$1"
-
+echo "MACHINE=$MACHINE"
 
 case "$MACHINE" in
         "porter")
@@ -43,6 +43,12 @@ case "$MACHINE" in
                 ;;
         "qemux86-64")
                 ;;
+        "dra7xx-evm")
+                ;;
+        "vayu")
+                # nickname for dra7xx-evm
+                MACHINE="dra7xx-evm"
+                ;;
         "wandboard")
                 ;;
         *)
@@ -51,14 +57,20 @@ case "$MACHINE" in
                 ;;
 esac
 
+echo "TEMPALTECONF=$TEMPLATECONF"
 # set template conf for each <board/device>
 if [ -z "$TEMPLATECONF" ]; then
+    # lookup meta-agl-demo first
     if [ -d "$PWD/meta-agl-demo/templates/$MACHINE/conf" ]; then
         TEMPLATECONF="$PWD/meta-agl-demo/templates/$MACHINE/conf"
+    # lookup meta-agl 2nd
+    elif [ -d "$PWD/meta-agl/templates/$MACHINE/conf" ]; then
+        TEMPLATECONF="$PWD/meta-agl/templates/$MACHINE/conf"
     fi
 fi
+echo "TEMPLATECONF=$TEMPLATECONF"
 
-echo "envsetup: Set '$1 as MACHINE."
+echo "envsetup: Set '$1' as MACHINE."
 export MACHINE
 
 # fallback
diff --git a/templates/common/conf-notes.txt b/templates/common/conf-notes.txt
new file mode 100644 (file)
index 0000000..45acdf5
--- /dev/null
@@ -0,0 +1,8 @@
+Common targets are:
+    agl-image-ivi
+    agl-image-ivi-crosssdk
+    agl-image-ivi-qa
+
+    agl-image-minimal
+    agl-image-weston
+
diff --git a/templates/dra7xx-evm/conf/bblayers.conf.sample b/templates/dra7xx-evm/conf/bblayers.conf.sample
new file mode 100644 (file)
index 0000000..a0ba47e
--- /dev/null
@@ -0,0 +1,27 @@
+# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
+# changes incompatibly
+LCONF_VERSION = "6"
+
+BBPATH = "${TOPDIR}"
+BBFILES ?= ""
+
+# AGL layers for TI vayu
+BBLAYERS ?= " \
+  ##OEROOT##/meta \
+  ##OEROOT##/meta-yocto \
+  ##OEROOT##/meta-yocto-bsp \
+  ##OEROOT##/../meta-agl/meta-ivi-common \
+  ##OEROOT##/../meta-agl/meta-agl \
+  ##OEROOT##/../meta-agl/meta-agl-bsp \
+  ##OEROOT##/../meta-openembedded/meta-oe \
+  ##OEROOT##/../meta-openembedded/meta-multimedia \
+  ##OEROOT##/../meta-openembedded/meta-efl \
+  ##OEROOT##/../meta-openembedded/meta-networking \
+  ##OEROOT##/../meta-openembedded/meta-python \
+  ##OEROOT##/../meta-ti \
+  "
+BBLAYERS_NON_REMOVABLE ?= " \
+  ##OEROOT##/meta \
+  ##OEROOT##/meta-yocto \
+  ##OEROOT##/../meta-agl/meta-agl \
+  "
diff --git a/templates/dra7xx-evm/conf/conf-notes.txt b/templates/dra7xx-evm/conf/conf-notes.txt
new file mode 120000 (symlink)
index 0000000..fc5c6a1
--- /dev/null
@@ -0,0 +1 @@
+../../common/conf-notes.txt
\ No newline at end of file
diff --git a/templates/dra7xx-evm/conf/local.conf.sample b/templates/dra7xx-evm/conf/local.conf.sample
new file mode 100644 (file)
index 0000000..140a30d
--- /dev/null
@@ -0,0 +1,265 @@
+#
+# AGL
+#####
+
+MACHINE = "dra7xx-evm"
+
+## ATTENTION, this is needed right now to build meta-ti with AGL: ##
+## due to meta-ti being based on YP 1.8 instead of YP 2.0
+BBMASK  = "meta-ti/.*eudev"
+
+#
+# END AGL
+#########
+
+#
+# This file is your local configuration file and is where all local user settings
+# are placed. The comments in this file give some guide to the options a new user
+# to the system might want to change but pretty much any configuration option can
+# be set in this file. More adventurous users can look at local.conf.extended
+# which contains other examples of configuration which can be placed in this file
+# but new users likely won't need any of them initially.
+#
+# Lines starting with the '#' character are commented out and in some cases the
+# default values are provided as comments to show people example syntax. Enabling
+# the option is a question of removing the # character and making any change to the
+# variable as required.
+
+#
+# Machine Selection
+#
+# You need to select a specific machine to target the build with. There are a selection
+# of emulated machines available which can boot and run in the QEMU emulator:
+#
+#MACHINE ?= "qemuarm"
+#MACHINE ?= "qemumips"
+#MACHINE ?= "qemuppc"
+#MACHINE ?= "qemux86"
+#MACHINE ?= "qemux86-64"
+#
+# There are also the following hardware board target machines included for
+# demonstration purposes:
+#
+#MACHINE ?= "beaglebone"
+#MACHINE ?= "genericx86"
+#MACHINE ?= "genericx86-64"
+#MACHINE ?= "mpc8315e-rdb"
+#MACHINE ?= "edgerouter"
+#
+# This sets the default machine to be qemux86 if no other machine is selected:
+MACHINE ??= "qemux86-64"
+
+#
+# Where to place downloads
+#
+# During a first build the system will download many different source code tarballs
+# from various upstream projects. This can take a while, particularly if your network
+# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
+# can preserve this directory to speed up this part of subsequent builds. This directory
+# is safe to share between multiple builds on the same machine too.
+#
+# The default is a downloads directory under TOPDIR which is the build directory.
+#
+#DL_DIR ?= "${TOPDIR}/downloads"
+
+#
+# Where to place shared-state files
+#
+# BitBake has the capability to accelerate builds based on previously built output.
+# This is done using "shared state" files which can be thought of as cache objects
+# and this option determines where those files are placed.
+#
+# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
+# from these files if no changes were made to the configuration. If changes were made
+# to the configuration, only shared state files where the state was still valid would
+# be used (done using checksums).
+#
+# The default is a sstate-cache directory under TOPDIR.
+#
+#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
+
+#
+# Where to place the build output
+#
+# This option specifies where the bulk of the building work should be done and
+# where BitBake should place its temporary files and output. Keep in mind that
+# this includes the extraction and compilation of many applications and the toolchain
+# which can use Gigabytes of hard disk space.
+#
+# The default is a tmp directory under TOPDIR.
+#
+#TMPDIR = "${TOPDIR}/tmp"
+
+#
+# Default policy config
+#
+# The distribution setting controls which policy settings are used as defaults.
+# The default value is fine for general Yocto project use, at least initially.
+# Ultimately when creating custom policy, people will likely end up subclassing
+# these defaults.
+#
+#DISTRO ?= "poky"
+DISTRO ?= "poky-agl"
+# As an example of a subclass there is a "bleeding" edge policy configuration
+# where many versions are set to the absolute latest code from the upstream
+# source control systems. This is just mentioned here as an example, its not
+# useful to most new users.
+# DISTRO ?= "poky-bleeding"
+
+#
+# Package Management configuration
+#
+# This variable lists which packaging formats to enable. Multiple package backends
+# can be enabled at once and the first item listed in the variable will be used
+# to generate the root filesystems.
+# Options are:
+#  - 'package_deb' for debian style deb files
+#  - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
+#  - 'package_rpm' for rpm style packages
+# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
+# We default to rpm:
+PACKAGE_CLASSES ?= "package_rpm"
+
+#
+# SDK/ADT target architecture
+#
+# This variable specifies the architecture to build SDK/ADT items for and means
+# you can build the SDK packages for architectures other than the machine you are
+# running the build on (i.e. building i686 packages on an x86_64 host).
+# Supported values are i686 and x86_64
+#SDKMACHINE ?= "i686"
+
+#
+# Extra image configuration defaults
+#
+# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
+# images. Some of these options are added to certain image types automatically. The
+# variable can contain the following options:
+#  "dbg-pkgs"       - add -dbg packages for all installed packages
+#                     (adds symbol information for debugging/profiling)
+#  "dev-pkgs"       - add -dev packages for all installed packages
+#                     (useful if you want to develop against libs in the image)
+#  "ptest-pkgs"     - add -ptest packages for all ptest-enabled packages
+#                     (useful if you want to run the package test suites)
+#  "tools-sdk"      - add development tools (gcc, make, pkgconfig etc.)
+#  "tools-debug"    - add debugging tools (gdb, strace)
+#  "eclipse-debug"  - add Eclipse remote debugging support
+#  "tools-profile"  - add profiling tools (oprofile, exmap, lttng, valgrind)
+#  "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
+#  "debug-tweaks"   - make an image suitable for development
+#                     e.g. ssh root access has a blank password
+# There are other application targets that can be used here too, see
+# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
+# We default to enabling the debugging tweaks.
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+
+#
+# Additional image features
+#
+# The following is a list of additional classes to use when building images which
+# enable extra features. Some available options which can be included in this variable
+# are:
+#   - 'buildstats' collect build statistics
+#   - 'image-mklibs' to reduce shared library files size for an image
+#   - 'image-prelink' in order to prelink the filesystem image
+#   - 'image-swab' to perform host system intrusion detection
+# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
+# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
+USER_CLASSES ?= "buildstats image-mklibs image-prelink"
+
+#
+# Runtime testing of images
+#
+# The build system can test booting virtual machine images under qemu (an emulator)
+# after any root filesystems are created and run tests against those images. To
+# enable this uncomment this line. See classes/testimage(-auto).bbclass for
+# further details.
+#TEST_IMAGE = "1"
+#
+# Interactive shell configuration
+#
+# Under certain circumstances the system may need input from you and to do this it
+# can launch an interactive shell. It needs to do this since the build is
+# multithreaded and needs to be able to handle the case where more than one parallel
+# process may require the user's attention. The default is iterate over the available
+# terminal types to find one that works.
+#
+# Examples of the occasions this may happen are when resolving patches which cannot
+# be applied, to use the devshell or the kernel menuconfig
+#
+# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
+# Note: currently, Konsole support only works for KDE 3.x due to the way
+# newer Konsole versions behave
+#OE_TERMINAL = "auto"
+# By default disable interactive patch resolution (tasks will just fail instead):
+PATCHRESOLVE = "noop"
+
+#
+# Disk Space Monitoring during the build
+#
+# Monitor the disk space during the build. If there is less that 1GB of space or less
+# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
+# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
+# of the build. The reason for this is that running completely out of space can corrupt
+# files and damages the build in ways which may not be easily recoverable.
+BB_DISKMON_DIRS = "\
+    STOPTASKS,${TMPDIR},1G,100K \
+    STOPTASKS,${DL_DIR},1G,100K \
+    STOPTASKS,${SSTATE_DIR},1G,100K \
+    ABORT,${TMPDIR},100M,1K \
+    ABORT,${DL_DIR},100M,1K \
+    ABORT,${SSTATE_DIR},100M,1K"
+
+#
+# Shared-state files from other locations
+#
+# As mentioned above, shared state files are prebuilt cache data objects which can
+# used to accelerate build time. This variable can be used to configure the system
+# to search other mirror locations for these objects before it builds the data itself.
+#
+# This can be a filesystem directory, or a remote url such as http or ftp. These
+# would contain the sstate-cache results from previous builds (possibly from other
+# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
+# cache locations to check for the shared objects.
+# NOTE: if the mirror uses the same structure as SSTATE_DIR, you need to add PATH
+# at the end as shown in the examples below. This will be substituted with the
+# correct path within the directory structure.
+#SSTATE_MIRRORS ?= "\
+#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
+#file://.* file:///some/local/dir/sstate/PATH"
+
+
+#
+# Qemu configuration
+#
+# By default qemu will build with a builtin VNC server where graphical output can be
+# seen. The two lines below enable the SDL backend too. This assumes there is a
+# libsdl library available on your build system.
+PACKAGECONFIG_append_pn-qemu-native = " sdl"
+PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
+ASSUME_PROVIDED += "libsdl-native"
+
+###############
+#
+# AGL specifics
+#
+###############
+
+# AGL includes all kernel modules here for ease-of-use during development.
+# Comment this out to be able to select the kernel modules yourself.
+IMAGE_INSTALL_append = " kernel-modules"
+
+# Likewise as we included all kernel modules by default in the filesystem,
+# we do not need a separate tarball stored.
+# Comment this out to receive the separate modules tarbal again.
+MODULE_TARBALL_DEPLOY ?= "0"
+
+###############
+# /END AGL
+###############
+
+
+# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
+# track the version of this file when it was generated. This can safely be ignored if
+# this doesn't mean anything to you.
+CONF_VERSION = "1"
index cb8af86..9b0e383 100644 (file)
@@ -5,6 +5,7 @@ LCONF_VERSION = "6"
 BBPATH = "${TOPDIR}"
 BBFILES ?= ""
 
+# AGL layers for MinnowBoard MAX (Intel)
 BBLAYERS ?= " \
   ##OEROOT##/meta \
   ##OEROOT##/meta-yocto \
deleted file mode 100644 (file)
index 80246306e544d425603b182d6ddad409835b1540..0000000000000000000000000000000000000000
+++ /dev/null
@@ -1,7 +0,0 @@
-Common targets are:
-    agl-image-ivi
-    agl-image-ivi-crosssdk
-    agl-image-ivi-qa
-
-    agl-image-minimal
-    agl-image-weston
new file mode 120000 (symlink)
index 0000000000000000000000000000000000000000..fc5c6a1b80f912573c81b30536669ac31b28e2e7
--- /dev/null
@@ -0,0 +1 @@
+../../common/conf-notes.txt
\ No newline at end of file
index 325d597..8ff3abd 100644 (file)
@@ -1,5 +1,7 @@
 # Machine Selection: MinnowBoard MAX
 MACHINE ?= "intel-corei7-64"
+# Commnet out below if want to use QtWebkit
+PACKAGECONFIG_remove_pn-qtquick1 = "webkit"
 
 #
 # This file is your local configuration file and is where all local user settings
@@ -243,6 +245,25 @@ IMAGE_INSTALL_append = " kernel-modules"
 # Comment this out to receive the separate modules tarbal again.
 MODULE_TARBALL_DEPLOY ?= "0"
 
+# Configurations to run on VirtualBox/VMWare
+#
+# To get wide screen than default, there are a selection of resolutions
+# available:
+#
+#APPEND += "uvesafb.mode_option=1024x768-32"
+#APPEND += "uvesafb.mode_option=1280x1024-32"
+#APPEND += "uvesafb.mode_option=1600x1200-32"
+#
+# To avoid corrupt boot screen by systemd message, you can use serial
+# console separated from VGA console or disable all boot messages by
+# kernel command line.
+#
+# Configuration for serial console
+#APPEND += "console=ttyS0,115200n8"
+#
+# All boot message will be off
+#APPEND += "quiet"
+
 ###############
 # /END AGL
 ###############
index ae0786f..b3047f7 100644 (file)
@@ -5,6 +5,7 @@ LCONF_VERSION = "6"
 BBPATH = "${TOPDIR}"
 BBFILES ?= ""
 
+# AGL layers for QEMUx86-64
 BBLAYERS ?= " \
   ##OEROOT##/meta \
   ##OEROOT##/meta-yocto \
deleted file mode 100644 (file)
index 80246306e544d425603b182d6ddad409835b1540..0000000000000000000000000000000000000000
+++ /dev/null
@@ -1,7 +0,0 @@
-Common targets are:
-    agl-image-ivi
-    agl-image-ivi-crosssdk
-    agl-image-ivi-qa
-
-    agl-image-minimal
-    agl-image-weston
new file mode 120000 (symlink)
index 0000000000000000000000000000000000000000..fc5c6a1b80f912573c81b30536669ac31b28e2e7
--- /dev/null
@@ -0,0 +1 @@
+../../common/conf-notes.txt
\ No newline at end of file
index c2da6e6..c28e2f1 100644 (file)
@@ -1,3 +1,9 @@
+# Machine Selection: QEMUx86-64
+MACHINE ?= "qemux86-64"
+
+# Commnet out below if want to use QtWebkit
+PACKAGECONFIG_remove_pn-qtquick1 = "webkit"
+
 #
 # This file is your local configuration file and is where all local user settings
 # are placed. The comments in this file give some guide to the options a new user
@@ -240,6 +246,25 @@ IMAGE_INSTALL_append = " kernel-modules"
 # Comment this out to receive the separate modules tarbal again.
 MODULE_TARBALL_DEPLOY ?= "0"
 
+# Configurations to run on VirtualBox/VMWare
+#
+# To get wide screen than default, there are a selection of resolutions
+# available:
+#
+#APPEND += "uvesafb.mode_option=1024x768-32"
+APPEND += "uvesafb.mode_option=1280x1024-32"
+#APPEND += "uvesafb.mode_option=1600x1200-32"
+#
+# To avoid corrupt boot screen by systemd message, you can use serial
+# console separated from VGA console or disable all boot messages by
+# kernel command line.
+#
+# Configuration for serial console
+APPEND += "console=ttyS0,115200n8"
+#
+# All boot message will be off
+APPEND += "quiet"
+
 ###############
 # /END AGL
 ###############
index ae0786f..b3047f7 100644 (file)
@@ -5,6 +5,7 @@ LCONF_VERSION = "6"
 BBPATH = "${TOPDIR}"
 BBFILES ?= ""
 
+# AGL layers for QEMUx86-64
 BBLAYERS ?= " \
   ##OEROOT##/meta \
   ##OEROOT##/meta-yocto \
deleted file mode 100644 (file)
index 80246306e544d425603b182d6ddad409835b1540..0000000000000000000000000000000000000000
+++ /dev/null
@@ -1,7 +0,0 @@
-Common targets are:
-    agl-image-ivi
-    agl-image-ivi-crosssdk
-    agl-image-ivi-qa
-
-    agl-image-minimal
-    agl-image-weston
new file mode 120000 (symlink)
index 0000000000000000000000000000000000000000..fc5c6a1b80f912573c81b30536669ac31b28e2e7
--- /dev/null
@@ -0,0 +1 @@
+../../common/conf-notes.txt
\ No newline at end of file
index 1dc84f5..9c58d9d 100644 (file)
@@ -1,5 +1,9 @@
 # Machine Selection: QEMUx86
 MACHINE ?= "qemux86"
+
+# Commnet out below if want to use QtWebkit
+PACKAGECONFIG_remove_pn-qtquick1 = "webkit"
+
 #
 # This file is your local configuration file and is where all local user settings
 # are placed. The comments in this file give some guide to the options a new user
@@ -242,6 +246,25 @@ IMAGE_INSTALL_append = " kernel-modules"
 # Comment this out to receive the separate modules tarbal again.
 MODULE_TARBALL_DEPLOY ?= "0"
 
+# Configurations to run on VirtualBox/VMWare
+#
+# To get wide screen than default, there are a selection of resolutions
+# available:
+#
+#APPEND += "uvesafb.mode_option=1024x768-32"
+APPEND += "uvesafb.mode_option=1280x1024-32"
+#APPEND += "uvesafb.mode_option=1600x1200-32"
+#
+# To avoid corrupt boot screen by systemd message, you can use serial
+# console separated from VGA console or disable all boot messages by
+# kernel command line.
+#
+# Configuration for serial console
+APPEND += "console=ttyS0,115200n8"
+#
+# All boot message will be off
+APPEND += "quiet"
+
 ###############
 # /END AGL
 ###############
index aea73b2..1714e1f 100644 (file)
@@ -5,6 +5,7 @@ LCONF_VERSION = "6"
 BBPATH = "${TOPDIR}"
 BBFILES ?= ""
 
+# AGL layers for Wandboard (NXP/Freescale)
 BBLAYERS ?= " \
   ##OEROOT##/meta \
   ##OEROOT##/meta-yocto \
deleted file mode 100644 (file)
index f91379f98c378d3939fe1fbe57077f5bd18910ee..0000000000000000000000000000000000000000
+++ /dev/null
@@ -1,6 +0,0 @@
-Common targets are:
-    agl-image-ivi
-    agl-image-ivi-crosssdk
-
-    agl-image-minimal
-    agl-image-weston
new file mode 120000 (symlink)
index 0000000000000000000000000000000000000000..fc5c6a1b80f912573c81b30536669ac31b28e2e7
--- /dev/null
@@ -0,0 +1 @@
+../../common/conf-notes.txt
\ No newline at end of file
index 5334a89..a6f4d40 100644 (file)
@@ -1,5 +1,7 @@
-# Machine Selection: MinnowBoard MAX
-MACHINE ?= "wandboard"
+# Machine Selection: wandboard
+MACHINE = "wandboard"
+# Commnet out below if want to use QtWebkit
+PACKAGECONFIG_remove_pn-qtquick1 = "webkit"
 
 #
 # This file is your local configuration file and is where all local user settings
@@ -243,6 +245,25 @@ IMAGE_INSTALL_append = " kernel-modules"
 # Comment this out to receive the separate modules tarbal again.
 MODULE_TARBALL_DEPLOY ?= "0"
 
+# Configurations to run on VirtualBox/VMWare
+#
+# To get wide screen than default, there are a selection of resolutions
+# available:
+#
+#APPEND += "uvesafb.mode_option=1024x768-32"
+#APPEND += "uvesafb.mode_option=1280x1024-32"
+#APPEND += "uvesafb.mode_option=1600x1200-32"
+#
+# To avoid corrupt boot screen by systemd message, you can use serial
+# console separated from VGA console or disable all boot messages by
+# kernel command line.
+#
+# Configuration for serial console
+#APPEND += "console=ttyS0,115200n8"
+#
+# All boot message will be off
+#APPEND += "quiet"
+
 ###############
 # /END AGL
 ###############