Update linux kernel for QEMUx86-64 and Minnowboard MAX 13/5313/4
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Tue, 19 Jan 2016 09:25:09 +0000 (18:25 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 21 Jan 2016 21:21:45 +0000 (21:21 +0000)
Update linux kernel for QEMUx86-64 and Minnowboard MAX
to compatile with YP 2.0 jethro's.

  - On QEMU in jethro, mouse not work with linux-3.17
  - KVM becomes avairable when CPU support it

E.g. command lines to run qemu with kvm and serial console

  $ cd tmp/deploy/images/qemux86-64
  $ runqemu bzImage-qemux86-64.bin \
    agl-demo-platform-qemux86-64.ext4 \
    qemuparams="-m 512 -usbdevice tablet" serial kvm

Change-Id: Ia35b8d5e25c03094994041eaf399b8476e6a6b6c
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
meta-agl-bsp/recipes-kernel/linux/linux-yocto_3.14%.bbappend [new file with mode: 0644]
meta-agl/conf/distro/poky-agl.conf

index 6b8483e..6f1ed9b 100644 (file)
@@ -1,8 +1,7 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
 
 # Extra configuration options for the QEMU kernel
-SRC_URI += "file://0001-fanotify-fix-notification-of-groups-with-inode-mount.patch \
-            file://fanotify.cfg \
+SRC_URI += "file://fanotify.cfg \
             file://uinput.cfg \
             file://hid.cfg \
             "
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_3.14%.bbappend b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_3.14%.bbappend
new file mode 100644 (file)
index 0000000..fe9c05c
--- /dev/null
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
+
+SRC_URI += " file://0001-fanotify-fix-notification-of-groups-with-inode-mount.patch"
index 65248d0..b631f87 100644 (file)
@@ -28,13 +28,13 @@ DISTRO_FEATURES ?= "${DISTRO_FEATURES_DEFAULT} ${DISTRO_FEATURES_LIBC} ${AGL_DEF
 DISTRO_FEATURES_remove = "x11"
 DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"
 
-PREFERRED_VERSION_linux-yocto ?= "3.14%"
-PREFERRED_VERSION_linux-yocto_qemux86 ?= "3.14%"
-PREFERRED_VERSION_linux-yocto_qemux86-64 ?= "3.14%"
-PREFERRED_VERSION_linux-yocto_qemuarm ?= "3.14%"
-PREFERRED_VERSION_linux-yocto_qemumips ?= "3.14%"
-PREFERRED_VERSION_linux-yocto_qemumips64 ?= "3.14%"
-PREFERRED_VERSION_linux-yocto_qemuppc ?= "3.14%"
+PREFERRED_VERSION_linux-yocto ?= "4.1%"
+PREFERRED_VERSION_linux-yocto_qemux86 ?= "4.1%"
+PREFERRED_VERSION_linux-yocto_qemux86-64 ?= "4.1%"
+PREFERRED_VERSION_linux-yocto_qemuarm ?= "4.1%"
+PREFERRED_VERSION_linux-yocto_qemumips ?= "4.1%"
+PREFERRED_VERSION_linux-yocto_qemumips64 ?= "4.1%"
+PREFERRED_VERSION_linux-yocto_qemuppc ?= "4.1%"
 
 # Prefer GStreamer 1.4.x by default
 PREFERRED_VERSION_gstreamer1.0              ?= "1.4.%"