HVAC plugin: support Yocto 2.0, merge AGL patches 61/5261/2
authorManuel Bachmann <mbc@iot.bzh>
Tue, 12 Jan 2016 09:24:45 +0000 (09:24 +0000)
committerGerrit Code Review <gerrit@172.30.200.200>
Tue, 12 Jan 2016 11:56:11 +0000 (11:56 +0000)
This commit :
- fixes CMakeLists.txt for CMake 3.3.1 (Yocto 2.0) ;
- merges Jan-Simon MÃller's AGL patch for cross-compilation
(gerrit.automotivelinux.org/gerrit/gitweb?p=AGL/meta-agl
.git;a=commit;h=8c7ab6abb2baae052ac5477ae45a35460da6b2df).

Change-Id: I317eade139d0c7f637bb603fd9301a0a5ce134c3
Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
meta-agl/recipes-automotive/hvacplugin/files/0001-Fix-boost-include-statement.patch [deleted file]
meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb

diff --git a/meta-agl/recipes-automotive/hvacplugin/files/0001-Fix-boost-include-statement.patch b/meta-agl/recipes-automotive/hvacplugin/files/0001-Fix-boost-include-statement.patch
deleted file mode 100644 (file)
index c936d8a..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-From 2f29b6dea548be861e6f1d0be1b0b7f83a2b3037 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Jan-Simon=20M=C3=B6ller?= <dl9pf@gmx.de>
-Date: Mon, 4 Jan 2016 02:19:24 +0100
-Subject: [PATCH] Fix boost include statement
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This patch fixes a cross-compilation issue with hvacplugin.
-The absolute path set for Boost_INCLUDE_DIRS is not
-cross-compilation save.
-According to https://cmake.org/Wiki/CMake:How_To_Find_Libraries
-we better use find_package(Boost REQUIRED) .
-
-Otherwise bitbake might fail with:
-ERROR: QA Issue: hvacplugin: The compile log indicates that 
-       host include and/or library paths were used.
-       Please check the log .../hvacplugin/0.1-r0/temp/log.do_compile'
-       for more information. [compile-host-path]
-ERROR: QA run found fatal errors. Please consider fixing them.
-ERROR: Function failed: do_package_qa
-
-Due to:
-cc1plus: warning: include location "/usr/include/boost" is unsafe 
-for cross-compilation [-Wpoison-system-directories]
-
-Signed-off-by: Jan-Simon Möller <dl9pf@gmx.de>
----
- CMakeLists.txt | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f8d0e5b..f100736 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -6,7 +6,8 @@ pkg_check_modules(gio gio-2.0)
- pkg_check_modules(gio-unix gio-unix-2.0)
- pkg_check_modules(json-c json-c)
- pkg_check_modules(amb automotive-message-broker)
--set(Boost_INCLUDE_DIRS /usr/include/boost)
-+#set(Boost_INCLUDE_DIRS /usr/include/boost)
-+find_package(Boost REQUIRED)
- include_directories(${CMAKE_SOURCE_DIR}/lib ${include_dirs} ${gio_INCLUDE_DIRS} ${gio-unix_INCLUDE_DIRS} ${CMAKE_SOURCE_DIR}/plugins/common ${Boost_INCLUDE_DIRS} ${json-c_INCLUDE_DIRS} ${amb_INCLUDE_DIRS}) 
--- 
-2.6.2
-
index 1d73c72..62e008b 100644 (file)
@@ -6,9 +6,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
 
 SRC_URI = "git://github.com/iotbzh/hvacplugin \
            file://hvacplugin \
-           file://0001-Fix-boost-include-statement.patch \
           "
-SRCREV = "253e3d98505108f652ba875544fde4f58d4714c8"
+SRCREV = "00cb8ff4084d635d3a929cb41b8d853f6c4baf76"
 S = "${WORKDIR}/git"
 
 DEPENDS = "glib-2.0 json-c automotive-message-broker"