Add package group and bitbake target for Quality Assurance 87/5387/4
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Wed, 10 Feb 2016 10:20:25 +0000 (19:20 +0900)
committerGerrit Code Review <gerrit@172.30.200.200>
Mon, 14 Mar 2016 13:33:45 +0000 (13:33 +0000)
New packagegroup and bitbake target are added which
includes utilities for testing distribution.
It is assumed to be used in the Quality Assurance of AGL Distro.

New package group: packagegroup-agl-test
                   packagegroup-ivi-common-test
New target: agl-image-ivi-qa

Change-Id: Ifb20d8a140dd71de6c464499e1b07fd9a0e36457
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
meta-agl/recipes-ivi/images/agl-image-ivi-qa.bb [new file with mode: 0644]
meta-agl/recipes-test/packagegroups/packagegroup-agl-test.bb [new file with mode: 0644]
meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb [new file with mode: 0644]
templates/intel-corei7-64/conf/conf-notes.txt
templates/qemux86-64/conf/conf-notes.txt
templates/qemux86/conf/conf-notes.txt

diff --git a/meta-agl/recipes-ivi/images/agl-image-ivi-qa.bb b/meta-agl/recipes-ivi/images/agl-image-ivi-qa.bb
new file mode 100644 (file)
index 0000000..bd06266
--- /dev/null
@@ -0,0 +1,11 @@
+SUMMARY = "A basic system of AGL distribution of IVI profile for Quality Assurance(QA)"
+DESCRIPTION = "A basic set of AGL Distribution. This image also has additional \
+packages (e.g. commandline tools) for Quality Assurance(QA)."
+
+require agl-image-ivi.bb
+
+IMAGE_INSTALL_append = " \
+    packagegroup-agl-test \
+    packagegroup-ivi-common-test \
+    "
+
diff --git a/meta-agl/recipes-test/packagegroups/packagegroup-agl-test.bb b/meta-agl/recipes-test/packagegroups/packagegroup-agl-test.bb
new file mode 100644 (file)
index 0000000..2a18cbc
--- /dev/null
@@ -0,0 +1,15 @@
+SUMMARY = "Utilities for testing of AGL"
+DESCRIPTION = "A set of packages required by testing AGL for Quality Assurance"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-test \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    "
diff --git a/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb b/meta-ivi-common/recipes-test/packagegroups/packagegroup-ivi-common-test.bb
new file mode 100644 (file)
index 0000000..e613d43
--- /dev/null
@@ -0,0 +1,15 @@
+SUMMARY = "Utilities for testing of AGL"
+DESCRIPTION = "A set of common packages required by testing AGL for Quality Assurance"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-ivi-common-test \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    "
index f91379f..8024630 100644 (file)
@@ -1,6 +1,7 @@
 Common targets are:
     agl-image-ivi
     agl-image-ivi-crosssdk
+    agl-image-ivi-qa
 
     agl-image-minimal
     agl-image-weston
index f91379f..8024630 100644 (file)
@@ -1,6 +1,7 @@
 Common targets are:
     agl-image-ivi
     agl-image-ivi-crosssdk
+    agl-image-ivi-qa
 
     agl-image-minimal
     agl-image-weston
index f91379f..8024630 100644 (file)
@@ -1,6 +1,7 @@
 Common targets are:
     agl-image-ivi
     agl-image-ivi-crosssdk
+    agl-image-ivi-qa
 
     agl-image-minimal
     agl-image-weston