meta-agl: AMB source plugin to control HVAC added by Microchip/K2L, replace of change... 71/4471/3
authorYury Asheshov <yury.asheshov@k2l.de>
Mon, 14 Dec 2015 14:25:21 +0000 (15:25 +0100)
committerManuel Bachmann <mbc@iot.bzh>
Tue, 15 Dec 2015 17:38:51 +0000 (17:38 +0000)
1. The source of the JVAC AMB plugin into meta-agl
2. GPLv2
3. Filenames fixed (hvacplugin)
4. Bitbake receipe added

Change-Id: I3fb92bafc616777735695212a793c851657cbf1b
Signed-off-by: Yury Asheshov <yury.asheshov@k2l.de>
meta-agl/recipes-automotive/hvacplugin/files/hvacplugin [new file with mode: 0644]
meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb [new file with mode: 0644]
meta-agl/recipes-core/packagegroups/packagegroup-agl-core-automotive.bb

diff --git a/meta-agl/recipes-automotive/hvacplugin/files/hvacplugin b/meta-agl/recipes-automotive/hvacplugin/files/hvacplugin
new file mode 100644 (file)
index 0000000..8a1a90d
--- /dev/null
@@ -0,0 +1,7 @@
+{
+       "name" : "hvacplugin",
+       "path" : "/usr/lib/automotive-message-broker/hvacplugin.so",
+       "delay" : "30",
+       "enabled" : true
+}
+
diff --git a/meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb b/meta-agl/recipes-automotive/hvacplugin/hvacplugin_0.1.bb
new file mode 100644 (file)
index 0000000..9692e2d
--- /dev/null
@@ -0,0 +1,26 @@
+SUMMARY = "hvacplugin"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+                    file://hvacplugin.cpp;startline=4;endline=11;md5=5adb69b6702cd5745961047a30ef560a"
+
+SRC_URI = "git://github.com/iotbzh/hvacplugin \
+           file://hvacplugin \
+          "
+SRCREV = "253e3d98505108f652ba875544fde4f58d4714c8"
+S = "${WORKDIR}/git"
+
+DEPENDS = "glib-2.0 json-c automotive-message-broker"
+RDEPENDS_{PN} = "automotive-message-broker"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE += "-DPLUGIN_INSTALL_PATH=${libdir}/automotive-message-broker"
+
+do_install_append() {
+       install -Dm 0644 ${WORKDIR}/hvacplugin ${D}/${sysconfdir}/ambd/plugins.d/hvacplugin
+}
+
+FILES_${PN} += "${libdir}/automotive-message-broker/*.so"
+FILES_${PN}-dbg += "${libdir}/automotive-message-broker/.debug"
+