Provide RTL-SDR 0.5.3 (RTL2832U chips, AM/FM radio support) 93/4393/1
authorManuel Bachmann <mbc@iot.bzh>
Tue, 1 Dec 2015 15:16:26 +0000 (15:16 +0000)
committerManuel Bachmann <mbc@iot.bzh>
Tue, 1 Dec 2015 15:19:08 +0000 (15:19 +0000)
RTL2832U-based USB dongles provide a convenient hardware
interface for AM/FM radio reception, which is actively
required by AGL 1.0 specification (AGL:4.2.1.1).

This is also required by the AM/FM radio QML plugin
(https://github.com/iotbzh/qml_radio_plugin).

(this is an original recipe, because it does not fit
general-purpose repositories such as meta-openembedded,
but the constructor does not have an official Yocto
repository yet)

Change-Id: I1a0298e7a110181f86f9ec93dcea1567bb2c0379
Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
meta-agl/recipes-connectivity/rtl-sdr/rtl-sdr_0.5.3.bb [new file with mode: 0644]
meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-connectivity.bb

diff --git a/meta-agl/recipes-connectivity/rtl-sdr/rtl-sdr_0.5.3.bb b/meta-agl/recipes-connectivity/rtl-sdr/rtl-sdr_0.5.3.bb
new file mode 100644 (file)
index 0000000..7a5fe3f
--- /dev/null
@@ -0,0 +1,17 @@
+SUMMARY = "Turns a Realtek RTL2832U-based DVB dongle into a SDR receiver"
+DESCRIPTION = "DVB-T dongles based on the Realtek RTL2832U chipset can be used as Software Digital Radio adapters, since the chip allows transferring raw I/Q samples to the host, which is really used for DAB/DAB+/FM demodulation."
+HOMEPAGE = "http://sdr.osmocom.org/trac/wiki/rtl-sdr"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
+                    file://src/librtlsdr.c;endline=18;md5=1b05599c3ebd4d74857a0a7c45f3d4ef"
+
+DEPENDS = "libusb1"
+
+SRC_URI = "git://git.osmocom.org/rtl-sdr"
+SRCREV = "df9596b2d1ebd36cdb14549cfdd76c25092e14d0"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-driver-detach"
index 405c0fb..664180d 100644 (file)
@@ -12,6 +12,7 @@ ALLOW_EMPTY_${PN} = "1"
 
 RDEPENDS_${PN} += "\
     ofono \
+    rtl-sdr \
     rygel \
     rygel-plugin-media-export \
     rygel-plugin-lms \