AMB (automotive-message-broker): depend on python-misc/json
[AGL/meta-agl.git] / meta-ivi-common / recipes-automotive / automotive-message-broker / automotive-message-broker_git.bb
index b921b99..7c49e6c 100644 (file)
@@ -11,15 +11,16 @@ inherit cmake systemd
 
 PV = "0.12+git${SRCPV}"
 
-# The 'gpsd' cause conflict bluez4 and bluez5 because
+# The 'gpsd' leads to a conflict between bluez4 and bluez5 because
 # meta-openembedded/meta-oe/recipes-navigation/gpsd/gpsd_3.10.bb is able to
-# select  bluez4 only instead AGL Distro choosed bluez5 at Changes 4141.
+# select  bluez4 only instead AGL Distro choose bluez5 at changeset 4141.
 # <https://gerrit.automotivelinux.org/gerrit/#/c/4141/>
 #
 # As temporary treatment, removing 'gpsd' from DEPENDS will let bitbake to build correctly.
 #
 #DEPENDS = "glib-2.0 util-linux sqlite3 qtbase boost json-c libtool gpsd"
 DEPENDS = "glib-2.0 util-linux sqlite3 boost json-c libtool"
+RDEPENDS_${PN} = "python-misc python-json"
 
 SRC_URI = "git://github.com/otcshare/automotive-message-broker.git"
 SRCREV = "ac3fe53327a13afc571efe079a31a0472ea285a3"
@@ -33,6 +34,12 @@ SYSTEMD_SERVICE_${PN} = "ambd.service"
 
 S = "${WORKDIR}/git"
 
+# amb detects icecc in cmake and would override the 
+# compiler selection of yocto. This breaks the build
+# if icecc is installed on the host.
+# -> Disable the detection in cmake.
+EXTRA_OECMAKE += " -Denable_icecc=OFF"
+
 do_install_append() {
     mv ${D}/usr/include/amb/* ${D}/usr/include