Introduce meta-agl-profile-core and meta-agl-profile-graphics
[AGL/meta-agl.git] / meta-agl / recipes-graphics / wayland / weston / 0007-ivi-shell-linked-libweston-desktop-and-added-structs.patch
diff --git a/meta-agl/recipes-graphics/wayland/weston/0007-ivi-shell-linked-libweston-desktop-and-added-structs.patch b/meta-agl/recipes-graphics/wayland/weston/0007-ivi-shell-linked-libweston-desktop-and-added-structs.patch
deleted file mode 100644 (file)
index 9286ba0..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index cdf82ab4..d990d400 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -993,6 +993,7 @@ ivi_shell_la_LDFLAGS = -module -avoid-version
- ivi_shell_la_LIBADD =                         \
-       libshared.la                            \
-       libweston-@LIBWESTON_MAJOR@.la          \
-+      libweston-desktop-@LIBWESTON_MAJOR@.la  \
-       $(COMPOSITOR_LIBS)
- ivi_shell_la_CFLAGS = $(AM_CFLAGS) $(COMPOSITOR_CFLAGS)
- ivi_shell_la_SOURCES =                                \
-diff --git a/ivi-shell/ivi-layout-private.h b/ivi-shell/ivi-layout-private.h
-index fe5be01a..c054130b 100644
---- a/ivi-shell/ivi-layout-private.h
-+++ b/ivi-shell/ivi-layout-private.h
-@@ -30,6 +30,7 @@
- #include "compositor.h"
- #include "ivi-layout-export.h"
-+#include "libweston-desktop/libweston-desktop.h"
- struct ivi_layout_view {
-       struct wl_list link;    /* ivi_layout::view_list */
-@@ -52,6 +53,7 @@ struct ivi_layout_surface {
-       struct ivi_layout *layout;
-       struct weston_surface *surface;
-+      struct weston_desktop_surface *weston_desktop_surface;
-       struct ivi_layout_surface_properties prop;
-diff --git a/ivi-shell/ivi-shell.c b/ivi-shell/ivi-shell.c
-index f3156d35..84db2c97 100644
---- a/ivi-shell/ivi-shell.c
-+++ b/ivi-shell/ivi-shell.c
-@@ -44,7 +44,7 @@
- #include "ivi-shell.h"
- #include "ivi-application-server-protocol.h"
--#include "ivi-layout-export.h"
-+#include "ivi-layout-private.h"
- #include "ivi-layout-shell.h"
- #include "shared/helpers.h"
- #include "compositor/weston.h"
-@@ -271,6 +271,8 @@ application_surface_create(struct wl_client *client,
-               return;
-       }
-+      layout_surface->weston_desktop_surface = NULL;
-+
-       ivisurf = zalloc(sizeof *ivisurf);
-       if (ivisurf == NULL) {
-               wl_resource_post_no_memory(resource);
-diff --git a/ivi-shell/ivi-shell.h b/ivi-shell/ivi-shell.h
-index e35f75f2..be430853 100644
---- a/ivi-shell/ivi-shell.h
-+++ b/ivi-shell/ivi-shell.h
-@@ -30,6 +30,7 @@
- #include <stdint.h>
- #include "compositor.h"
-+#include "libweston-desktop/libweston-desktop.h"
- struct ivi_shell
- {
-@@ -37,6 +38,7 @@ struct ivi_shell
-       struct weston_compositor *compositor;
-+      struct weston_desktop *desktop;
-       struct wl_list ivi_surface_list; /* struct ivi_shell_surface::link */
-       struct text_backend *text_backend;