run-(agl-)postinst: Emit progress to console
[AGL/meta-agl.git] / meta-agl / recipes-devtools / run-postinsts / run-postinsts_%.bbappend
diff --git a/meta-agl/recipes-devtools/run-postinsts/run-postinsts_%.bbappend b/meta-agl/recipes-devtools/run-postinsts/run-postinsts_%.bbappend
new file mode 100644 (file)
index 0000000..fc327b6
--- /dev/null
@@ -0,0 +1,5 @@
+do_configure_append() {
+       if ! grep -q StandardOutput= ${WORKDIR}/run-postinsts.service; then
+               sed -i '/ExecStart=/iStandardOutput=journal+console' ${WORKDIR}/run-postinsts.service
+       fi
+}