Introduce meta-agl-profile-core and meta-agl-profile-graphics
[AGL/meta-agl.git] / meta-agl / recipes-core / psplash / psplash_git.bbappend
diff --git a/meta-agl/recipes-core/psplash/psplash_git.bbappend b/meta-agl/recipes-core/psplash/psplash_git.bbappend
deleted file mode 100644 (file)
index bdc196b..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-SRC_URI += "file://psplash-colors.h \
-            file://psplash-start.service \
-            file://psplash-quit.service \
-            file://psplash-anim \
-            "
-
-SPLASH_IMAGES="file://psplash-poky-img.h;outsuffix=default"
-
-inherit systemd
-
-SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${PN}', '', d)}"
-SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'psplash-start.service psplash-quit.service', '', d)}"
-
-do_configure_append () {
-       cd ${S}
-       cp ../psplash-colors.h ./
-}
-
-do_install_append () {
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${systemd_unitdir}/system
-        install -m 644 ${WORKDIR}/*.service ${D}/${systemd_unitdir}/system
-    fi
-    install -m 755 ${WORKDIR}/psplash-anim ${D}/${bindir}
-}