Introduce meta-agl-profile-core and meta-agl-profile-graphics
[AGL/meta-agl.git] / meta-agl / recipes-core / packagegroups / packagegroup-core-boot-agl.bb
diff --git a/meta-agl/recipes-core/packagegroups/packagegroup-core-boot-agl.bb b/meta-agl/recipes-core/packagegroups/packagegroup-core-boot-agl.bb
deleted file mode 100644 (file)
index c9d6798..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-#
-# Copyright (C) 2007 OpenedHand Ltd.
-#
-# derived from oe-core: meta/recipes-core/packagegroups/packagegroup-core-boot.bb
-
-SUMMARY = "Minimal boot requirements"
-DESCRIPTION = "The minimal set of packages required to boot the system"
-LICENSE = "MIT"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-inherit packagegroup
-
-#
-# Set by the machine configuration with packages essential for device bootup
-#
-MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
-MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
-
-# Distro can override the following VIRTUAL-RUNTIME providers:
-VIRTUAL-RUNTIME_dev_manager ?= "udev"
-VIRTUAL-RUNTIME_login_manager ?= "busybox"
-VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
-VIRTUAL-RUNTIME_initscripts ?= "initscripts"
-VIRTUAL-RUNTIME_keymaps ?= "keymaps"
-
-SYSVINIT_SCRIPTS = "${@bb.utils.contains('MACHINE_FEATURES', 'rtc', 'busybox-hwclock', '', d)} \
-                    modutils-initscripts \
-                    init-ifupdown \
-                    ${VIRTUAL-RUNTIME_initscripts} \
-                   "
-
-RDEPENDS_${PN} = "\
-    base-files \
-    base-passwd \
-    busybox \
-    run-agl-postinsts \
-    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "${SYSVINIT_SCRIPTS}", "", d)} \
-    ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
-    netbase \
-    ${VIRTUAL-RUNTIME_login_manager} \
-    ${VIRTUAL-RUNTIME_init_manager} \
-    ${VIRTUAL-RUNTIME_dev_manager} \
-    ${VIRTUAL-RUNTIME_update-alternatives} \
-    ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS}"
-
-RRECOMMENDS_${PN} = "\
-    tzdata \
-    ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS}"
-