Enable ACP for HDMI on RaspberryPi4.
[AGL/meta-agl.git] / meta-agl-bsp / meta-intel / recipes-kernel / linux / linux-intel_4.19%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 # adding most supported USB Bluetooth, Wifi, and Ethernet devices
4 SRC_URI_append = " file://usb-devices.cfg"
5 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
6
7 # adding support for other graphic cards to work on more PC HW
8 SRC_URI_append = " file://extra-graphic-devices.cfg"
9 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
10
11 # adding internal network in kernel for network boot
12 SRC_URI_append = " file://net-devices.cfg"
13 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/net-devices.cfg"
14
15 # adding specific driver needed by the upsquare board
16 SRC_URI_append = " file://upsquare.cfg"
17 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/upsquare.cfg"
18
19 # adding CONFIG needed by LAVA and NBD
20 SRC_URI_append = " file://lava.cfg"
21 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/lava.cfg"
22
23 # Ensure we have a startup.nsh file
24 SRC_URI_append = " file://startup.nsh"
25
26 do_deploy_append() {
27         install -m 0755 ${WORKDIR}/startup.nsh ${DEPLOYDIR}/
28 }