radio: Update default presets location 67/22367/1
authorScott Murray <scott.murray@konsulko.com>
Mon, 9 Sep 2019 23:58:59 +0000 (19:58 -0400)
committerScott Murray <scott.murray@konsulko.com>
Mon, 9 Sep 2019 23:58:59 +0000 (19:58 -0400)
Since the changes to run the applications as non-root, the location
of the default preset file has not matched with the agl-driver user
the application runs as.  Since simply changing the install location
to /home/1001 would require some post-install SMACK label tinkering,
and is perhaps fragile to the application user, the files are now
instead installed to /etc/xdg/AGL, with the defaults to be used named
radio-presets.conf.  A corresponding change to the radio application
to look in that location before trying the appdata directory is also
required.

Bug-AGL: SPEC-2789

Change-Id: Ic5756420e21471096b74b476ad243e44e87ef561
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/radio/radio_git.bb

index 3316176..52a981f 100644 (file)
@@ -25,18 +25,14 @@ inherit qmake5 aglwgt
 
 # ALS, CES, FOSDEM available
 AGL_RADIO_PRESETS_LOCALE ?= "CES"
-
 do_install_append() {
-    install -d ${D}${ROOT_HOME}/app-data/radio
-    install -m 0644 ${WORKDIR}/presets-CES.conf ${D}${ROOT_HOME}/app-data/radio/
-    install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}${ROOT_HOME}/app-data/radio/
-    install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}${ROOT_HOME}/app-data/radio/
-    install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${ROOT_HOME}/app-data/radio/presets.conf
+    install -d ${D}${sysconfdir}/xdg/AGL
+    install -m 0644 ${WORKDIR}/presets-CES.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-CES.conf
+    install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-ALS.conf
+    install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-FOSDEM.conf
+    install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
 }
 
-FILES_${PN} += " \
-       ${ROOT_HOME}/app-data/radio/presets-*.conf \
-       ${ROOT_HOME}/app-data/radio/presets.conf \
-"
+FILES_${PN} += "${sysconfdir}/xdg/AGL/*"
 
 RDEPENDS_${PN} += "agl-service-radio"