html5-mixer: create recipe and add to html5 demo 57/23757/2
authorLorenzo Tilve <ltilve@igalia.com>
Thu, 6 Feb 2020 18:00:44 +0000 (19:00 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 7 Feb 2020 14:57:00 +0000 (14:57 +0000)
Bug-AGL: SPEC-2824

Change-Id: Icc15a48d2a78dfdd57bf60f050ec0b66c714aefa
Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
recipes-demo-hmi/html5-mixer/html5-mixer_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb

diff --git a/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb b/recipes-demo-hmi/html5-mixer/html5-mixer_git.bb
new file mode 100644 (file)
index 0000000..babef57
--- /dev/null
@@ -0,0 +1,25 @@
+SUMMARY     = "AGL HTML5 Mixer Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-mixer/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+  cd ${B}
+  npm install
+}
+
+do_aglwgt_package()  {
+  cd ${B}
+  npm run build
+}
index b739039..7feb122 100644 (file)
@@ -22,6 +22,7 @@ AGL_APPS = " \
     html5-launcher \
     html5-hvac \
     html5-settings \
+    html5-mixer \
     "
 
 RDEPENDS_${PN}_append = " \