qtlocation: remove local patch 94/23694/1
authorScott Murray <scott.murray@konsulko.com>
Wed, 22 Jan 2020 18:15:25 +0000 (13:15 -0500)
committerScott Murray <scott.murray@konsulko.com>
Mon, 27 Jan 2020 20:05:54 +0000 (15:05 -0500)
Remove local patch to qtlocation as it has been applied upstream.

Bug-AGL: SPEC-2932

Change-Id: Ib89b6e7c7bb43514c9676224331773324078bd1f
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch [deleted file]
recipes-qt/qt5/qtlocation_git.bbappend [deleted file]

diff --git a/recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch b/recipes-qt/qt5/qtlocation/0001-Fix-unstable-rotation-gesture.patch
deleted file mode 100644 (file)
index 164c9f0..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From 85df79b094d1097108a28424d6f9b3b76b3aee62 Mon Sep 17 00:00:00 2001
-From: Tasuku Suzuki <tasuku.suzuki@qt.io>
-Date: Thu, 8 Nov 2018 15:26:57 +0900
-Subject: [PATCH] Fix unstable rotation gesture
-
-Order of touch events are not sorted on some platform. When touch point
-1 and
-2 are swapped, map is rotated 180 degrees in a moment
-
-Change-Id: I9c308b805a6ca54519f26a9ff19217de7f947c17
-Reviewed-by: Paolo Angelelli <paolo.angelelli@qt.io>
----
- src/location/declarativemaps/qquickgeomapgesturearea.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/location/declarativemaps/qquickgeomapgesturearea.cpp b/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-index c6f4b42..576aeee 100644
---- a/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-+++ b/src/location/declarativemaps/qquickgeomapgesturearea.cpp
-@@ -1087,6 +1087,7 @@ void QQuickGeoMapGestureArea::update()
-     m_allPoints << m_touchPoints;
-     if (m_allPoints.isEmpty() && !m_mousePoint.isNull())
-         m_allPoints << *m_mousePoint.data();
-+    std::sort(m_allPoints.begin(), m_allPoints.end(), [](const QTouchEvent::TouchPoint &tp1, const QTouchEvent::TouchPoint &tp2) { return tp1.id() < tp2.id(); });
-     touchPointStateMachine();
--- 
-2.7.4
-
diff --git a/recipes-qt/qt5/qtlocation_git.bbappend b/recipes-qt/qt5/qtlocation_git.bbappend
deleted file mode 100644 (file)
index e0f3a6b..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-
-SRC_URI += " \
-    file://0001-Fix-unstable-rotation-gesture.patch \
-"