vboxguestdrivers: add vboxguestdrivers 6.0.10 recipe
[AGL/meta-agl-demo.git] / recipes-support / vboxguestdrivers / vboxguestdrivers / Makefile.utils
diff --git a/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils b/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
new file mode 100644 (file)
index 0000000..495601f
--- /dev/null
@@ -0,0 +1,45 @@
+## -----------------------------------------------------------------------
+##
+##   Copyright 2001-2008 H. Peter Anvin - All Rights Reserved
+##
+##   This program is free software; you can redistribute it and/or modify
+##   it under the terms of the GNU General Public License as published by
+##   the Free Software Foundation, Inc., 53 Temple Place Ste 330,
+##   Boston MA 02111-1307, USA; either version 2 of the License, or
+##   (at your option) any later version; incorporated herein by reference.
+##
+## -----------------------------------------------------------------------
+
+INCLUDES = -I. -I../vboxsf -I../vboxsf/include
+MOD_DEFS = -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 \
+           -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0
+CFLAGS  = ${INCLUDES} ${MOD_DEFS}
+LDFLAGS         =
+
+SRCS     = mount.vboxsf.c \
+           vbsfmount.c
+
+OBJS    = $(patsubst %.c,%.o,$(notdir $(SRCS)))
+
+.SUFFIXES: .c .o .i .s .S
+
+
+all: mount.vboxsf
+
+clean:
+       -rm -f *.o mount.vboxsf
+
+spotless: clean
+       -rm -f *~
+
+mount.vboxsf: $(OBJS)
+       $(CC) $(LDFLAGS) -o $@ $^
+
+%.o: %.c
+       $(CC) $(UMAKEDEPS) $(CFLAGS) -c -o $@ $<
+%.i: %.c
+       $(CC) $(UMAKEDEPS) $(CFLAGS) -E -o $@ $<
+%.s: %.c
+       $(CC) $(UMAKEDEPS) $(CFLAGS) -S -o $@ $<
+
+-include .*.d *.tmp