Update LIN demo to use lin-config
[AGL/meta-agl-demo.git] / recipes-support / lin-config / lin-config_git.bb
index 6c8db84..e83f716 100644 (file)
@@ -2,7 +2,6 @@ DESCRIPTION = "lin-config tool for the sllin driver module"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-
 DEPENDS += "libnl libxml2"
 
 SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https"
@@ -11,17 +10,16 @@ S = "${WORKDIR}/git/lin_config/src"
 
 SRC_URI_append = " \
        file://0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch \
+       file://0002-Change-Makefile-to-use-LDFLAGS.patch \
        "
 
 inherit pkgconfig
 
 PV = "0.1+git${SRCPV}"
 
-
 do_configure[noexec] = "1"
 
 do_install_append() {
-
     install -d ${D}/${bindir}
-    install -m 644 ${S}/lin_config ${D}/${bindir}
-}
\ No newline at end of file
+    install -m 755 ${S}/lin_config ${D}/${bindir}
+}